Bug 967954 - zathura-ps 0.2.2 broken debuginfo
zathura-ps 0.2.2 broken debuginfo
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: zathura-ps (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2013-05-28 12:15 EDT by Ville Skyttä
Modified: 2013-06-07 23:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: girara-0.1.6-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:42:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-05-28 12:15:46 EDT
zathura-ps-fix_install.patch was removed when updating to 0.2.2, but this causes the *.so be built again in %install, and that time without the -g flag, thus breaking debuginfo.

When fixing this, I'd suggest also adding VERBOSE=1 to %build's make invocation so more information about the build is output.

Also, there's no %changelog entry for 0.2.2-1.
Comment 1 Ville Skyttä 2013-05-28 12:18:02 EDT
Looks like zathura-djvu 0.2.3-1 and zathura-pdf-poppler 0.2.3-1 have the same regression too.
Comment 2 François Cami 2013-05-28 12:32:50 EDT
Petr, could you fix these please?
Comment 3 Petr Šabata 2013-05-29 04:16:16 EDT
Oops!

Thanks for catching that.  I'll revert that change.
Comment 4 François Cami 2013-05-29 04:33:59 EDT
We could probably use sed like this:
sed -ie "s/install:\ all/install:\ /g" Makefile
instead of adding the patch again.
Comment 5 Fedora Update System 2013-05-29 11:37:22 EDT
girara-0.1.6-2.fc19,zathura-0.2.3-4.fc19,zathura-ps-0.2.2-2.fc19,zathura-pdf-poppler-0.2.3-2.fc19,zathura-djvu-0.2.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/girara-0.1.6-2.fc19,zathura-0.2.3-4.fc19,zathura-ps-0.2.2-2.fc19,zathura-pdf-poppler-0.2.3-2.fc19,zathura-djvu-0.2.3-2.fc19
Comment 6 Fedora Update System 2013-05-30 13:52:56 EDT
Package girara-0.1.6-2.fc19, zathura-0.2.3-4.fc19, zathura-ps-0.2.2-2.fc19, zathura-pdf-poppler-0.2.3-2.fc19, zathura-djvu-0.2.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing girara-0.1.6-2.fc19 zathura-0.2.3-4.fc19 zathura-ps-0.2.2-2.fc19 zathura-pdf-poppler-0.2.3-2.fc19 zathura-djvu-0.2.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9651/girara-0.1.6-2.fc19,zathura-0.2.3-4.fc19,zathura-ps-0.2.2-2.fc19,zathura-pdf-poppler-0.2.3-2.fc19,zathura-djvu-0.2.3-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-07 23:42:39 EDT
girara-0.1.6-2.fc19, zathura-0.2.3-4.fc19, zathura-ps-0.2.2-2.fc19, zathura-pdf-poppler-0.2.3-2.fc19, zathura-djvu-0.2.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.