Bug 967957 - BuildRequires of lcms-package is missing gcc-c++
BuildRequires of lcms-package is missing gcc-c++
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lcms (Show other bugs)
19
All All
unspecified Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 12:24 EDT by Matthias Hensler
Modified: 2013-05-28 18:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 18:16:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Hensler 2013-05-28 12:24:58 EDT
Description of problem:
../libtool: line 1312: g++: command not found
make[1]: *** [_lcms_la-lcms_wrap.lo] Error 1
make[1]: Leaving directory `/root/rpmbuild/BUILD/lcms-1.19/python'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.JkvwEw (%build)


Version-Release number of selected component (if applicable):
1.19-9.fc19

How reproducible:
Always on fresh installation


Steps to Reproduce:
1. install F19-beta
2. install lcms.src.rpm and try to build it
3. 

Actual results:
After initial dependencies are installed the build process starts and then breaks with above error, since g++ was not installed.


Expected results:
Should not start building if gcc-c++ is not installed.


Additional info:
Just add a "BuildRequires: gcc-c++" line to the specfile
Comment 1 Nicolas Chauvet (kwizart) 2013-05-28 18:16:04 EDT
Nope, gcc-g++ is in the default build requirement, so this is a bug in your infra.

You need to use yum groupinstall buildsys-build

Note You need to log in before you can comment on or make changes to this bug.