Bug 967965 - Document the creation and use of provider networks.
Document the creation and use of provider networks.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.0
Assigned To: Stephen Gordon
ecs-bugs
: Documentation
: 953395 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 12:54 EDT by Stephen Gordon
Modified: 2014-08-03 19:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Installation_and_Configuration_Guide-3-en-US-3-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-03 19:50:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-05-28 12:54:24 EDT
>>> "It is recommended that users use a provider network rather than the L3
>>> agent to provide external network access until such time as network
>>> namespaces support is available."
>>>
>>> Do we have documentation on using provider networks in Quantum already?
>>>  Or do we need more detail here?
>>>
>>> Bob?
>>
>> I know this is documented upstream, but I'm not sure if its covered in
>> the RHOS documentation.
> 
> That's a negative, is this still going to be desirable/required once we have namespaces support?

Yes - definitely desirable, and maybe required. The same provider
attributes are needed to use a provider external network with the
l3-agent. With linuxbridge, this is the only way to define an external
network, and I recommend it for openvswitch (in place of setting
external_network_bridge = br-ex) as well. In general, I think we need to
support both direct access to external networks (as provider networks
that VMs connect to) and routed access to external networks (via
l3-agent + provider network).

-Bob
Comment 1 Stephen Gordon 2013-06-04 11:32:07 EDT
*** Bug 953395 has been marked as a duplicate of this bug. ***
Comment 2 Stephen Gordon 2013-06-04 16:40:58 EDT
Added:
  10.1.3. OpenStack Networking API Extensions
  10.6.  Configuring a Provider Network

Updated:
  10.7.  Configuring the L3 Agent

Note You need to log in before you can comment on or make changes to this bug.