Bug 967989 - Crash blocked F19 upgrade
Crash blocked F19 upgrade
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
19
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 14:04 EDT by Kai Engert (:kaie)
Modified: 2013-05-29 17:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 17:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2013-05-28 14:04:08 EDT
Today I attempted to upgrade my F18 system to the latest pre-F19 snapshot.
I used the "yum distro-sync" apprach.

About 10% into the yum transaction, it stopped, and it looks like it stopped because of a crash in policycoreutils.

I have a full directory, as created by abrt, if you want it, let me know.
A few pieces from it:

cmdline:
/usr/bin/python -Es /usr/sbin/semanage fcontext -a -t textrel_shlib_t /usr/lib/libffmpegsumo.so.0.0.0

core_backtrace:
20a7b88131f2524123d1ac100683751417db4970 0x16 swig_import_helper /usr/lib64/python2.7/site-packages/selinux/__init__.py -
20a7b88131f2524123d1ac100683751417db4970 0x1a <module> /usr/lib64/python2.7/site-packages/selinux/__init__.py -
7901cf021cb461f86a9d7de470955d1f63ff89bb 0x18 <module> /usr/lib64/python2.7/site-packages/seobject.py -
f73c90a461c3223987d4be75eaa962e0112f7809 0x19 <module> /usr/sbin/semanage -

Note, this system had selinux disabled.
Comment 1 Daniel Walsh 2013-05-29 17:26:28 EDT
I have no idea why this would block the update.  I think it is probably a red herring.  The tools that is shipping libffmpegsumo.so.0.0.0 is not checking if SElinux is enabled which is potentially causing the error.  I would report a bug to them.

This command blowing up in a post install would not stop the update.

Note You need to log in before you can comment on or make changes to this bug.