Bug 968018 - Performance Issue - Systems Page -> Details tab for a system takes too long to load
Performance Issue - Systems Page -> Details tab for a system takes too long t...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 15:25 EDT by sthirugn@redhat.com
Modified: 2013-06-19 11:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 11:12:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-05-28 15:25:56 EDT
Description of problem:
Performance Issue - Systems Page -> Details tab for a system takes too long to load

Version-Release number of selected component (if applicable):
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-40.noarch
* foreman-postgresql-1.1.10002-40.noarch
* katello-1.4.2-7.el6sat.noarch
* katello-all-1.4.2-7.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-7.el6sat.noarch
* katello-configure-1.4.3-10.el6sat.noarch
* katello-configure-foreman-1.4.3-10.el6sat.noarch
* katello-foreman-all-1.4.2-7.el6sat.noarch
* katello-glue-candlepin-1.4.2-7.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
* katello-glue-pulp-1.4.2-7.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install satellite 6
2. Register and subscribe a client
3. Navigate to Satellite 6 UI -> Systems Page -> Select a System -> Click on Details tab

Actual results:
Details tab takes too long to load (possibly a performance issue?)

Expected results:
Details tab should not take too long to load

Additional info:
The same issue is found with other tabs too:
1. Details
2. Subscriptions
3. Content
4. System Groups
Comment 1 Justin Sherrill 2013-06-06 14:55:51 EDT
I am not able to reproduce this.  Was there a large number of systems or other types of content?  If i register a single system and do the above steps, all pages load within a second or two.  Anything else i need to do to reproduce?
Comment 2 Corey Welton 2013-06-19 11:12:44 EDT
I was unable to reproduce this using a sat6 host which had a single system registered and on a system with multiple (9) systems registered.

QE Closing - this bug can be reopened if the behavior is once again exhibited.

Note You need to log in before you can comment on or make changes to this bug.