Bug 968037 - RuntimeError: Can't have a question in command line mode!
RuntimeError: Can't have a question in command line mode!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
abrt_hash:2497f96b2ef7c5c0bd99ddec3a5...
:
Depends On:
Blocks: 1005384
  Show dependency treegraph
 
Reported: 2013-05-28 16:24 EDT by Jeff Bastian
Modified: 2014-04-07 11:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1005384 (view as bug list)
Environment:
Last Closed: 2014-04-07 11:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (361.99 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: anaconda.log (2.51 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: backtrace (381 bytes, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: environ (772 bytes, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: ifcfg.log (413 bytes, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: ks.cfg (984 bytes, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: lsblk_output (2.44 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: nmcli_dev_list (3.36 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: packaging.log (11.44 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: program.log (55.08 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: storage.log (204.91 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details
File: syslog (69.18 KB, text/plain)
2013-05-28 16:24 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2013-05-28 16:24:11 EDT
Description of problem:
I tried to kickstart install Fedora 19 and it crashed after complaining about not enough free disk space.
The following was filed automatically by anaconda:
anaconda 19.28-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 59, in prompt
    raise RuntimeError(errtxt)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 341, in _mainloop
    prompt = last_screen.prompt(self._screens[-1][1])
RuntimeError: Can't have a question in command line mode!

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:    ks=http://termite.dfw.redhat.com/kickstart/f19-lvm-raid1.ks
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 341, in _mainloop
    prompt = last_screen.prompt(self._screens[-1][1])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 59, in prompt
    raise RuntimeError(errtxt)
RuntimeError: Can't have a question in command line mode!
Comment 1 Jeff Bastian 2013-05-28 16:24:15 EDT
Created attachment 754070 [details]
File: anaconda-tb
Comment 2 Jeff Bastian 2013-05-28 16:24:19 EDT
Created attachment 754071 [details]
File: anaconda.log
Comment 3 Jeff Bastian 2013-05-28 16:24:22 EDT
Created attachment 754073 [details]
File: backtrace
Comment 4 Jeff Bastian 2013-05-28 16:24:26 EDT
Created attachment 754074 [details]
File: environ
Comment 5 Jeff Bastian 2013-05-28 16:24:29 EDT
Created attachment 754075 [details]
File: ifcfg.log
Comment 6 Jeff Bastian 2013-05-28 16:24:33 EDT
Created attachment 754076 [details]
File: ks.cfg
Comment 7 Jeff Bastian 2013-05-28 16:24:36 EDT
Created attachment 754077 [details]
File: lsblk_output
Comment 8 Jeff Bastian 2013-05-28 16:24:39 EDT
Created attachment 754078 [details]
File: nmcli_dev_list
Comment 9 Jeff Bastian 2013-05-28 16:24:43 EDT
Created attachment 754079 [details]
File: packaging.log
Comment 10 Jeff Bastian 2013-05-28 16:24:47 EDT
Created attachment 754080 [details]
File: program.log
Comment 11 Jeff Bastian 2013-05-28 16:24:52 EDT
Created attachment 754081 [details]
File: storage.log
Comment 12 Jeff Bastian 2013-05-28 16:24:55 EDT
Created attachment 754082 [details]
File: syslog
Comment 13 Jeff Bastian 2013-05-28 16:30:24 EDT
I added the "--all" flag to the clearpart line and that fixed my installation.


I also had an error on the "raid" line: it should be
  raid pv.01 --level=1 --device=md0 raid.01 raid.02
Comment 14 Aaron N Gray 2013-12-18 19:06:37 EST
Tried booting anaconda in cmdline mode

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20i386 cmdline nomodeset BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
package:        anaconda-19.30.13-1
product:        Fedora
reason:         RuntimeError: Can't have a question in command line mode!
release:        Cannot get release name.
version:        19
Comment 15 Samantha N. Bueno 2013-12-19 08:57:12 EST
If you're seeing this traceback, your kickstart file is missing some critical information. See: 
https://fedoraproject.org/wiki/Anaconda_Boot_Options?rd=Anaconda/Options#cmdline


However, this should error gracefully instead of throwing a traceback. Taking since I've also got the related RHEL bug.

Note You need to log in before you can comment on or make changes to this bug.