Bug 968064 - openjdk fault in native code
openjdk fault in native code
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 19:41 EDT by gcarter
Modified: 2013-11-18 10:30 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 12:45:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openJDK SIGSEGV (0xb) at pc=0x0000003882e6d9b1 (134.75 KB, text/x-log)
2013-06-18 09:15 EDT, Alix André Barbosa
no flags Details
Eclipse error log (140.20 KB, text/x-log)
2013-11-16 20:00 EST, Aidan Delaney
no flags Details

  None (edit)
Description gcarter 2013-05-28 19:41:35 EDT
Description of problem:
Open Jdk dies on startup of a new workspace for Eclipse Indigo.

Version-Release number of selected component (if applicable):
Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)

How reproducible:
Start Eclipse Indigo with a new workspace.

Steps to Reproduce:
1.Download Eclipse INDIGO
2.Start Eclipse INDIGO
3.Create a new workspace

Actual results:
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000003f3c66d9b1, pid=3724, tid=139944362301184
#
# JRE version: 7.0_19
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsoup-2.4.so.1+0x6d9b1]  soup_session_feature_detach+0x11
#

Expected results:
Shouldn't SIGSEGV.

Additional info:
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000003f3c66d9b1, pid=3724, tid=139944362301184
#
# JRE version: 7.0_19
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsoup-2.4.so.1+0x6d9b1]  soup_session_feature_detach+0x11
#
Comment 1 Mauricio Teixeira 2013-06-16 09:48:28 EDT
Same problem happens if you use Sun Java instead, so I don't think it's an OpenJDK problem, but a libsoup problem instead.
Comment 2 gcarter 2013-06-16 10:29:29 EDT
Yes, hence I specified this is a native code issue, (i.e. libsoup) nothing wrong per se with the Java VM code part of Eclipse.

This seems to have been resolved however, so I may close this bug out.

We shall see what happens.

-gc
Comment 3 Mauricio Teixeira 2013-06-17 10:02:14 EDT
Well, I stumble upon this problem yesterday morning on Fedora 19 Beta, so I'm guessing the problem persists.
Comment 4 Deepak Bhole 2013-06-17 10:28:05 EDT
Hi, do you have a full backtrace that you can attach? Thanks!
Comment 5 Mauricio Teixeira 2013-06-17 10:31:30 EDT
I have more or less the same thing as the original reporter. Running libsoup-2.42.2-1.fc19.x86_64.

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000003febe6d9b1, pid=31422, tid=140564483352320
#
# JRE version: 7.0_21-b11
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.21-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsoup-2.4.so.1+0x6d9b1]  soup_session_feature_detach+0x11
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /NotBackedUp/Titanium_Studio/hs_err_pid31422.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 6 Deepak Bhole 2013-06-17 10:34:45 EDT
Unfortunately that header is not useful to find the problem. 

However the /NotBackedUp/Titanium_Studio/hs_err_pid31422.log file might help if you still have it. If so, can you please post it? Thanks.
Comment 8 Alix André Barbosa 2013-06-18 09:15:03 EDT
Created attachment 762474 [details]
openJDK SIGSEGV (0xb) at pc=0x0000003882e6d9b1

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000003882e6d9b1, pid=13584, tid=139962714662656
#
# JRE version: OpenJDK Runtime Environment (8.0) (build 1.8.0-internal-0)
# Java VM: OpenJDK 64-Bit Server VM (25.0-b31-internal mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libsoup-2.4.so.1+0x6d9b1]  soup_session_feature_detach+0x11
#
# Core dump written. Default location: /home/alixbarbosa/ZendStudio/core or core.13584
#
# An error report file with more information is saved as:
# /home/alixbarbosa/ZendStudio/hs_err_pid13584.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 9 Deepak Bhole 2013-06-18 09:18:06 EDT
Based on the above, this us happening via SWT JNI code. The issue may lie in SWT or in libsoup, I am unsure. Assigning to Eclipse however, as there is no issue on JDK side.
Comment 10 Alexander Kurtakov 2013-06-18 09:53:38 EDT
If I read properly you guys are trying to use Indigo or ZendStudio (which version of eclipse platform is it based on ?) but the support for working with webkitgtk as new as the one in Fedora 19 is added only in the soon to be released Kepler (4.3). I strongly encourage you to do `yum install eclipse` and use eclipse which is part of Fedora as this is not OpenJDK issue nor we can fix other distributions (like ZendStudio) to work with newer webkit. 
Let me know if the problem persist with any Kepler build either Fedora or eclipse.org.
Comment 11 gcarter 2013-06-18 12:26:32 EDT
Well, due to the issues I have when I develop I use the Eclipse Kepler from the download site: 

http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/kepler/RC3/eclipse-standard-kepler-RC3-linux-gtk-x86_64.tar.gz

For a variety of reasons, I use the above version because I usually need the latest fixes.

So at the moment, I am using the above, and so far, it works fine with Fedora 19 and I have moved on from Indigo.

I plan on doing GDB source debugging today as well as using Valgrind, so we shall see how that works.

-gc
Comment 12 Alexander Kurtakov 2013-06-18 12:45:17 EDT
As per comment#11 I'm closing the bug as it was caused by using old eclipse that doesn't support the latest webkit.
Comment 13 Bradley 2013-06-25 11:07:46 EDT
I know this is closed, but the below workaround worked for me.  Add the below to eclipse.ini:

-Dorg.eclipse.swt.browser.DefaultType=mozilla

See same Ubuntu GNOME bug report:

https://bugs.launchpad.net/ubuntu-gnome/+bug/1163501

This doesn't just crash old Eclipse but also Aptana Studio and probably some others (where it may be more difficult to update the code to support the latest webkit), but it's upstream anyway.
Comment 14 Edouard Bourguignon 2013-07-24 12:12:54 EDT
same problem with Apache Directory Studio (which may rely on an old eclipse) on Fedora 19, have to add
org.eclipse.swt.browser.DefaultType=mozilla
in configuration/config.ini

hope it helps
Comment 15 Aidan Delaney 2013-11-16 20:00:40 EST
Created attachment 825031 [details]
Eclipse error log

I have the same issue running Indigo on Fedora 20 (I'd run the shipped version of Kepler, but the Google Web Toolkit plugin seems to make Kepler very unstable).

Note You need to log in before you can comment on or make changes to this bug.