Bug 968065 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesses on the unix_stream_socket unix_stream_socket.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesse...
Status: CLOSED DUPLICATE of bug 970119
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:dbde0e680c9d1069492d991a232...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 20:02 EDT by vinesh teotia
Modified: 2013-06-24 08:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 08:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-28 20:02:35 EDT
Description of problem:
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'getattr' accesses on the unix_stream_socket unix_stream_socket.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that totem-video-thumbnailer should be allowed getattr access on the unix_stream_socket unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep multiqueue0:src /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Objects                unix_stream_socket [ unix_stream_socket ]
Source                        multiqueue0:src
Source Path                   /usr/bin/totem-video-thumbnailer
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           totem-3.8.2-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.3-301.fc19.x86_64 #1 SMP Mon
                              May 20 12:50:56 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-05-23 21:47:18 IST
Last Seen                     2013-05-23 21:47:25 IST
Local ID                      b73e75f7-21e4-4c35-921c-534968d72890

Raw Audit Messages
type=AVC msg=audit(1369325845.550:425): avc:  denied  { getattr } for  pid=2344 comm="multiqueue0:src" path="socket:[25607]" dev="sockfs" ino=25607 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1369325845.550:425): arch=x86_64 syscall=fstat success=yes exit=0 a0=1 a1=7fe5e8820340 a2=7fe5e8820340 a3=10ad03c items=0 ppid=1787 pid=2344 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=multiqueue0:src exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: multiqueue0:src,thumb_t,xdm_t,unix_stream_socket,getattr

audit2allow

#============= thumb_t ==============
allow thumb_t xdm_t:unix_stream_socket getattr;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.3-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-29 08:42:10 EDT
Did you need to switch to permissive mode to make thumb working? What does

# ps -efZ |grep xdm
Comment 2 Miroslav Grepl 2013-06-24 08:07:42 EDT

*** This bug has been marked as a duplicate of bug 970119 ***

Note You need to log in before you can comment on or make changes to this bug.