Bug 968092 - Form fields for new host are scoped by location and organization on load
Form fields for new host are scoped by location and organization on load
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 22:09 EDT by Sam Kottler
Modified: 2014-06-18 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 14:58:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Kottler 2013-05-28 22:09:52 EDT
Description of problem:

1. Enable locations
2. Define resources for different locations
3. Login as a user with "any location" 
4. new host
5. the first location is selected but host groups wihtout locations are shown
6. when selecting one of those host groups, no puppet classes are shown

Expected:

Either no location selected and host groups selection working

or

host groups scoped by the location

Additional info:
Fixed upstream in f096806f4037d4ba1a78009f8faa01e693fe88a4.
Comment 1 Mike McCune 2013-05-29 18:36:33 EDT
mass-triage since these are all POST/MODIFIED
Comment 2 Corey Welton 2013-06-12 16:26:30 EDT
Testing notes:
[16:25] < dcleal> cswiii: edit /etc/foreman/settings.yaml, flip locations_enabled to true.
Comment 3 Corey Welton 2013-06-13 13:02:31 EDT
Moving to 6.0.2 for QE, users and roles from a katello+foreman perspective not yet implemented.
Comment 4 Dominic Cleal 2013-09-18 14:58:41 EDT
Shipped in MDP1.

Note You need to log in before you can comment on or make changes to this bug.