Bug 968097 - FactNames are not precreated
FactNames are not precreated
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 22:22 EDT by Sam Kottler
Modified: 2014-06-18 04:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 15:28:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Kottler 2013-05-28 22:22:52 EDT
Description of problem:
facts.keys.dup.delete_if { |n| fact_names.map(&:name).include? n } creates a tremendous overhead on the facts import from the puppet masters, this fix simply takes the code from the original Puppet::Rails::Host. As an example, imports have gone from ~30s to ~200ms

Additional info:
Fixed upstream in 7a158256e38e7ffd03dbe86962a4474720fafdfc.
Comment 1 Og Maciel 2013-05-28 22:24:40 EDT
How do you verify this?
Comment 2 Mike McCune 2013-05-29 18:36:40 EDT
mass-triage since these are all POST/MODIFIED
Comment 3 Corey Welton 2013-06-05 15:28:04 EDT
Devtask, QE closing.

Note You need to log in before you can comment on or make changes to this bug.