This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 968152 - [virtio-win][netkvm]BSOD(7E) always happen on Job of "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv" failed on HCK for win8-32
[virtio-win][netkvm]BSOD(7E) always happen on Job of "NDISTest6.0-[2 Machine]...
Status: CLOSED DUPLICATE of bug 960844
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 02:13 EDT by guo jiang
Modified: 2013-10-13 20:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 09:21:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file - win8-32 - Mini6RSSSendRecv (50.03 MB, application/x-zip-compressed)
2013-05-29 02:36 EDT, guo jiang
no flags Details

  None (edit)
Description guo jiang 2013-05-29 02:13:09 EDT
Description of problem:
BSOD with error 7E always happened on Job "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv" failed on HCK for win8-32. 

Version-Release number of selected component (if applicable):
    
   * Red Hat Enterprise Linux Server release 6.4 (Santiago)
   * kernel-2.6.32-369.el6.x86_64    
   * qemu-img-rhev-0.12.1.2-2.359.el6.x86_64
   * virtio-win-prewhql-0.1-61
   * spice-server-0.12.0-12.el6.x86_64
   * seabios-0.6.1.2-27.el6.x86_64
   * vgabios-0.6b-3.7.el6.noarch

How reproducible:
100% 

Steps to Reproduce:
1.Boot guest with CLI:
  test guest:/usr/libexec/qemu-kvm -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-32-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:53:12:52:21,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:34:25:13:45:12,bus=pci.0,addr=0x6 -uuid 4673cccf-3027-4ca4-89f3-1ffa0c49e92a -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-61-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -name win8-32-nic1-61-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
  support guest:/usr/libexec/qemu-kvm -m 2G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-32-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:13:33:52:52:21,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:12:53:25:45:12,bus=pci.0,addr=0x6 -uuid d3e76ade-17be-4042-a8d0-2e157bf9106f -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-61-nic2,server,nowait -mon chardev=111a,mode=readline -vnc :2 -vga cirrus -name win8-32-nic2-61-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.run job "NDISTest6.0-[2 Machine]- 2c_MiniRSSSendRecv"

3.Run task "Run NDISTest Client"

Actual results:
BSOD with error 7E happened.

Expected results:
Job should pass without any error.

Additional info:
Comment 1 guo jiang 2013-05-29 02:14:34 EDT
Windbg info:

3: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: 80000003, The exception code that was not handled
Arg2: 982e41ca, The address that the exception occurred at
Arg3: a65fbc50, Exception Record Address
Arg4: a65fb820, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid

FAULTING_IP: 
ndprot630+791ca
982e41ca cc              int     3

EXCEPTION_RECORD:  a65fbc50 -- (.exr 0xffffffffa65fbc50)
ExceptionAddress: 982e41ca (ndprot630+0x000791ca)
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 3
   Parameter[0]: 00000000
   Parameter[1]: a5005100
   Parameter[2]: 00000001

CONTEXT:  a65fb820 -- (.cxr 0xffffffffa65fb820)
eax=8741d570 ebx=84872040 ecx=8741d570 edx=00000001 esi=00004e20 edi=a5005100
eip=982e41ca esp=a65fbd18 ebp=a65fbd54 iopl=0         nv up ei ng nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00000286
ndprot630+0x791ca:
982e41ca cc              int     3
Resetting default scope

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_PARAMETER1:  00000000

EXCEPTION_PARAMETER2:  a5005100

EXCEPTION_PARAMETER3:  00000001

LAST_CONTROL_TRANSFER:  from 982f7310 to 982e41ca

STACK_TEXT:  
WARNING: Stack unwind information not available. Following frames may be wrong.
a65fbd54 982f7310 00000000 00000000 a65fbd78 ndprot630+0x791ca
a65fbd74 818cd415 8740da3c d852d8e2 00000000 ndprot630+0x8c310
a65fbdb0 81979039 982f72d0 8740da3c 00000000 nt!PspSystemThreadStartup+0x4a
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


FOLLOWUP_IP: 
ndprot630+791ca
982e41ca cc              int     3

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  ndprot630+791ca

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ndprot630

IMAGE_NAME:  ndprot630.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  5049be82

STACK_COMMAND:  .cxr 0xffffffffa65fb820 ; kb

FAILURE_BUCKET_ID:  AV_ndprot630+791ca

BUCKET_ID:  AV_ndprot630+791ca

Followup: MachineOwner
---------
Comment 2 guo jiang 2013-05-29 02:36:09 EDT
Created attachment 754198 [details]
dump file - win8-32 - Mini6RSSSendRecv
Comment 6 Yan Vugenfirer 2013-08-26 09:21:43 EDT

*** This bug has been marked as a duplicate of bug 960844 ***

Note You need to log in before you can comment on or make changes to this bug.