Bug 968170 - SELinux is preventing /usr/bin/bash from write, open access on the file /run/lock/subsys/vboxadd-service.
SELinux is preventing /usr/bin/bash from write, open access on the file /run/...
Status: CLOSED DUPLICATE of bug 966544
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2e38ae61bfcd210040e225b120e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 03:10 EDT by Moez Roy
Modified: 2013-05-29 06:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 06:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-05-29 03:10:34 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from write, open access on the file /run/lock/subsys/vboxadd-service.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that bash should be allowed write open access on the vboxadd-service file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep vboxadd-service /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:var_lock_t:s0
Target Objects                /run/lock/subsys/vboxadd-service [ file ]
Source                        vboxadd-service
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-300.fc19.x86_64 #1 SMP Fri
                              May 24 22:17:06 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-29 03:08:36 EDT
Last Seen                     2013-05-29 03:08:36 EDT
Local ID                      5012c869-aa66-4e00-9926-06447a3051aa

Raw Audit Messages
type=AVC msg=audit(1369811316.68:19): avc:  denied  { write open } for  pid=417 comm="vboxadd-service" path="/run/lock/subsys/vboxadd-service" dev="tmpfs" ino=15366 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=file


type=SYSCALL msg=audit(1369811316.68:19): arch=x86_64 syscall=open success=no exit=EACCES a0=1ff31d0 a1=241 a2=1b6 a3=0 items=0 ppid=1 pid=417 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=vboxadd-service exe=/usr/bin/bash subj=system_u:system_r:init_t:s0 key=(null)

Hash: vboxadd-service,init_t,var_lock_t,file,write,open

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-29 06:01:18 EDT

*** This bug has been marked as a duplicate of bug 966544 ***

Note You need to log in before you can comment on or make changes to this bug.