Bug 968190 - [RHEVM][backend] cannot assign VLAN to bond which is named other than bond[0-4]
[RHEVM][backend] cannot assign VLAN to bond which is named other than bond[0-4]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Lior Vernia
Martin Pavlik
network
:
: 988415 (view as bug list)
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-05-29 04:00 EDT by Martin Pavlik
Modified: 2016-02-10 14:47 EST (History)
13 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:12:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (230.52 KB, image/png)
2013-05-29 04:00 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17665 None None None Never
oVirt gerrit 18031 None None None Never

  None (edit)
Description Martin Pavlik 2013-05-29 04:00:58 EDT
Created attachment 754236 [details]
screenshot 1

Description of problem:

if user creates VLAN with tag 172 and add it to host over bond222 in GUI I get 

Error while executing action:

dell-05:

    Cannot setup Networks. The following Network Interfaces don't exist on the Host: bond222.

(see screenshot)


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.3.master.el6ev 

How reproducible:
always

Steps to Reproduce:
1. crete VLAN
2. create bond on host with name other than bond[0-4] (e.g. bond 222) and assign the VLAN to it (this has to be done in same instance of Setup Host Networks)


Actual results:
Cannot setup Networks. The following Network Interfaces don't exist on the Host: bond222.

Expected results:
bond222 is created and VLAN is assigned to it

Additional info:
procedure works if an empty bond is created in one instance of Setup Host Networks and VLAN is added to bond in second instance of Setup Host Networks

engine.log
2013-05-28 16:10:57,526 WARN  [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (ajp-/127.0.0.1:8702-1) [19dbbb25] CanDoAction of action SetupNetworks failed. Reasons:VAR__ACTION__SETUP,VAR__TYPE__NETWORKS,NETWORK_INTERFACES_DONT_EXIST,$NETWORK_INTERFACES_DONT_EXIST_LIST bond222
Comment 1 Dan Kenigsberg 2013-05-29 08:35:48 EDT
Martin, would you please report the version of vdsm?

Does bond222 actually exist on the dell-02 host?
Comment 2 Martin Pavlik 2013-05-29 08:58:13 EDT
(In reply to Dan Kenigsberg from comment #1)
> Martin, would you please report the version of vdsm?
> 
> Does bond222 actually exist on the dell-02 host?

[root@dell-r210ii-05 ~]# rpm -q vdsm
vdsm-4.10.3-0.416.git5358ed2.el6.x86_64

no bond222 does not exist on the host, I would expect it to be created, same way it happens when I put regular network over it
Comment 3 Dan Kenigsberg 2013-07-26 10:27:05 EDT
*** Bug 988415 has been marked as a duplicate of this bug. ***
Comment 4 Lior Vernia 2013-08-05 09:29:21 EDT
I'll get back to you on whether the other one's a duplicate or not, I don't think it is though because this clearly had to do with the VLAN and the other doesn't seem to.
Comment 5 Lior Vernia 2013-08-13 07:10:15 EDT
*** Bug 988415 has been marked as a duplicate of this bug. ***
Comment 6 Martin Pavlik 2013-08-14 08:40:02 EDT
works in is10
Comment 7 Itamar Heim 2014-01-21 17:12:31 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.