Bug 968191 - Headpin Nightly Default environment Library is not visible in UI
Headpin Nightly Default environment Library is not visible in UI
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-05-29 04:04 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:11:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Default Environment (50.03 KB, image/png)
2013-05-29 04:04 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2013-05-29 04:04:28 EDT
Created attachment 754237 [details]
Default Environment

Description of problem:
Headpin Nightly Default environment Library is not visible in UI 

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-glue-elasticsearch-1.4.2-1.git.469.ba512a5.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.41.e1043b5.el6.noarch
katello-cli-common-1.4.2-1.git.71.2a2d883.el6.noarch
katello-common-1.4.2-1.git.469.ba512a5.el6.noarch
katello-headpin-all-1.4.2-1.git.469.ba512a5.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.469.ba512a5.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-headpin-1.4.2-1.git.469.ba512a5.el6.noarch
katello-cli-1.4.2-1.git.71.2a2d883.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=***

Steps to Reproduce:
1.Login to UI as admin
2.Navigate Manage Organisations
3.Create + New Organisations
4.Navigate to Details page of selected Org
5.Check whether default environment is visible

Actual results:
Default environment is not visible

Expected results:
'Library' the default environment is seen in Org Details page


Additional info:
Screenshot attached
Comment 1 Bryan Kearney 2013-06-07 09:26:40 EDT
This appears to be fixed in the current release.
Comment 2 sthirugn@redhat.com 2013-07-05 16:01:55 EDT
(In reply to Bryan Kearney from comment #1)
> This appears to be fixed in the current release.

I am not sure if this is a bug in the first place.  There is no need to display the default environment in the Organization Details page. Please let me know what fix was made here.
Comment 3 Tom McKay 2013-07-22 13:41:00 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 97561cbdf6207bfda1428f9968fc1a43e28f8cec
      https://github.com/Katello/katello/commit/97561cbdf6207bfda1428f9968fc1a43e28f8cec
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-07-19 (Fri, 19 Jul 2013)

The Library environment should no longer be visible in the UI.
Comment 4 Bryan Kearney 2013-08-02 14:52:10 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 5 sthirugn@redhat.com 2013-08-08 18:05:18 EDT
Library environment is not visible in headpin UI anymore.

Version Tested:
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 7 errata-xmlrpc 2013-10-01 07:11:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.