Bug 968209 - Typing characters which are not explicitly listed as “valid_input_chars” in .conf files in ibus-typing-booster get inserted in a weird position
Typing characters which are not explicitly listed as “valid_input_chars” in ....
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 04:38 EDT by Mike FABIAN
Modified: 2013-06-13 02:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-typing-booster-0.0.32-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 01:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
what-happens-when-typing-characters-not-listed-as-valid-input-chars-in-ibus-typing-booster.png (129.46 KB, image/png)
2013-05-29 04:38 EDT, Mike FABIAN
no flags Details
what-happens-when-typing-characters-not-listed-as-valid-input-chars-in-ibus-typing-booster.ogv (193.66 KB, application/octet-stream)
2013-05-29 04:39 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-05-29 04:38:30 EDT
Created attachment 754258 [details]
what-happens-when-typing-characters-not-listed-as-valid-input-chars-in-ibus-typing-booster.png

ibus-typing-booster-0.0.29-1.fc19.noarch

When using for example the German ibus-typing-booster 
and typing
 
  gr☺ün

the result is

  ☺grün

because “☺” is not listed in the “valid_input_chars” variable in de_DE.conf.
All characters not listed there get inserted *before* the current preëdit.
Comment 1 Mike FABIAN 2013-05-29 04:39:40 EDT
Created attachment 754260 [details]
what-happens-when-typing-characters-not-listed-as-valid-input-chars-in-ibus-typing-booster.ogv

Video.
Comment 2 Fedora Update System 2013-05-29 12:44:20 EDT
ibus-typing-booster-0.0.31-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.31-1.fc17
Comment 3 Fedora Update System 2013-05-29 12:45:17 EDT
ibus-typing-booster-0.0.31-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.31-1.fc18
Comment 4 Fedora Update System 2013-05-29 12:46:27 EDT
ibus-typing-booster-0.0.31-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.31-1.fc19
Comment 5 Fedora Update System 2013-05-29 22:54:27 EDT
Package ibus-typing-booster-0.0.31-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-0.0.31-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9595/ibus-typing-booster-0.0.31-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-06-02 17:58:22 EDT
ibus-typing-booster-0.0.32-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.32-1.fc19
Comment 7 Fedora Update System 2013-06-02 18:00:40 EDT
ibus-typing-booster-0.0.32-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.32-1.fc17
Comment 8 Fedora Update System 2013-06-02 18:02:08 EDT
ibus-typing-booster-0.0.32-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-0.0.32-1.fc18
Comment 9 Fedora Update System 2013-06-13 01:55:08 EDT
ibus-typing-booster-0.0.32-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-06-13 02:06:35 EDT
ibus-typing-booster-0.0.32-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-06-13 02:36:00 EDT
ibus-typing-booster-0.0.32-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.