Bug 968213 - When namespaces is disabled a VM does not get a IP address.
When namespaces is disabled a VM does not get a IP address.
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.0
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 04:42 EDT by yfried
Modified: 2016-04-26 14:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
OpenStack Networking provided by the component formerly known as Quantum is only supported when network namespaces are enabled. Many common configurations rely on support for network namespaces and will not function correctly without them. As such the use of OpenStack Networking without a network namespaces enabled kernel, such as the one provided in this release, is not supported.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 01:12:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yfried 2013-05-29 04:42:53 EDT
Description of problem:
VMs can't get IP when NS is disabled - DHCP request is blocked by host's iptables

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. All in one setup
2. VM sends DHCP request
3. Request arrives at DHCP tap device. No answer
4. When disabling IP tables the above works 

Actual results:
DHCP requests are blocked by host's iptables

Expected results:
DHCP requested should be passed and IP assigned to VM

Additional info:
Comment 1 Perry Myers 2013-05-30 01:12:55 EDT
Our plan presently is to support Quantum only when network namespaces are enabled.  There are too many caveats and configurations that do not work when netns is disabled, such that it is not a supportable configuration for our customers.

Because of that, I am closing this bug as WONTFIX.  The workaround should be to enable network namespaces and use a kernel/userspace that supports netns.

Note You need to log in before you can comment on or make changes to this bug.