Bug 968232 - libvirt should managed all container created by virt-sandbox-service
libvirt should managed all container created by virt-sandbox-service
Status: CLOSED DUPLICATE of bug 988493
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt-sandbox (Show other bugs)
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Depends On:
  Show dependency treegraph
Reported: 2013-05-29 05:25 EDT by zhe peng
Modified: 2013-08-01 10:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-01 10:59:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description zhe peng 2013-05-29 05:25:04 EDT
Description of problem:
libvirt should managed all container created by virt-sandbox-service

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1: use virt-sandbox-service to create a container and start
#virt-sandbox-service create -C -u httpd.service http1

#virt-sandbox-service start http1

# virt-sandbox-service list --running

2: use virsh to check container status
#virsh -c lxc:/// list --all
 Id    Name                           State
 8072  http1                          running

3:destroy the container
#virsh -c lxc:/// destroy http1 
#virt-sandbox-service stop http1

4:check container status
# virsh -c lxc:/// list --all
 Id    Name                           State

5:define a container which name is same with stopped container,start the container by virt-sandbox-service will get error.
#virsh -c lxc:/// define http1.xml
Domain http1 defined from http1.xml

#virt-sandbox-service start http1
Unable to start container: Failed to create domain: operation failed: domain 'http1' already exists with uuid ea1a9e67-927d-4365-b735-9280b4414818

Actual results:
see step.

Expected results:
all container managed by libvirt, resolve conflict.

Additional info:
Comment 2 Daniel Berrange 2013-08-01 10:59:05 EDT

*** This bug has been marked as a duplicate of bug 988493 ***

Note You need to log in before you can comment on or make changes to this bug.