Bug 968236 - [kernel] failure: Cannot find file libc/__fc_builtin_for_normalization.i
[kernel] failure: Cannot find file libc/__fc_builtin_for_normalization.i
Status: CLOSED DUPLICATE of bug 888865
Product: Fedora
Classification: Fedora
Component: frama-c (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 05:30 EDT by Gwendal
Modified: 2013-05-29 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 09:50:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gwendal 2013-05-29 05:30:11 EDT
Description of problem:

I am using Fedora 18 x64. I've just installed frama-c, and it crashes at startup with the following error:
==================================================
[kernel] failure: Cannot find file libc/__fc_builtin_for_normalization.i, needed for Frama-C initialization. Please check that /usr/share/frama-c is the correct share path for Frama-C.
[kernel] The full backtrace is:
         Raised at file "src/kernel/log.ml", line 523, characters 30-31
         Called from file "src/kernel/log.ml", line 517, characters 9-16
         Re-raised at file "src/kernel/log.ml", line 520, characters 15-16
         Called from file "src/kernel/file.ml", line 169, characters 4-171
         Called from file "src/project/project.ml", line 367, characters 12-15
         Called from file "src/project/project.ml", line 372, characters 17-22
         Re-raised at file "src/project/project.ml", line 372, characters 56-57
         Called from file "queue.ml", line 135, characters 6-20
         Called from file "src/project/project.ml", line 303, characters 2-21
         Called from file "src/project/project.ml", line 314, characters 27-44
         Called from file "src/kernel/boot.ml", line 69, characters 17-43
         Called from file "src/kernel/cmdline.ml", line 197, characters 4-8
         
         Frama-C aborted: internal error.
         Please report as 'crash' at http://bts.frama-c.com/.
         Your Frama-C version is Oxygen-20120901.
         Note that a version and a backtrace alone often do not contain enough
         information to understand the bug. Guidelines for reporting bugs are at:
         http://bts.frama-c.com/dokuwiki/doku.php?id=mantis:frama-c:bug_reporting_guidelines
==================================================


Version-Release number of selected component (if applicable):

Nom                 : frama-c
Architecture        : x86_64
Version             : 1.8
Révision            : 5.fc18
Taille              : 70 M
Dépôt               : installed
Depuis le dépôt     : updates


How reproducible: Always


Steps to Reproduce:
1. yum install frama-c
2. frama-c


Actual results: The previous error message.


Expected results: Frama C should start.
Comment 1 Gwendal 2013-05-29 06:21:38 EDT
I've reported the bug to frama-c developpers as well: http://bts.frama-c.com/view.php?id=1433
Comment 2 Jerry James 2013-05-29 09:50:27 EDT
Thanks for the report, Erwan.  This is an artifact of how the frama-c and frama-c-devel packages were split.  It has been fixed for Fedora 19 and later.  For Fedora 18, please install the frama-c-devel package as a workaround.

*** This bug has been marked as a duplicate of bug 888865 ***
Comment 3 Gwendal 2013-05-29 12:35:53 EDT
Indeed, it works with frama-c-devel. Thanks!

Note You need to log in before you can comment on or make changes to this bug.