Bug 968247 - Update python-boto to >= 2.6.0 for EL 6.5
Update python-boto to >= 2.6.0 for EL 6.5
Status: CLOSED DUPLICATE of bug 999080
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-boto (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Steven Hardy
cloudforms-qe-dept
: Rebase
Depends On: 970134
Blocks: 883504 968246 973342
  Show dependency treegraph
 
Reported: 2013-05-29 05:59 EDT by Steven Hardy
Modified: 2016-04-26 10:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 13:39:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2013-05-29 05:59:59 EDT
Description of problem:

required by 968246, will require an update to python-boto >= 2.6.0 for cloud-init update to 0.7.2, probably due to:

https://bugs.launchpad.net/cloud-init/+bug/1068801

Note there was a major change between 2.5.x and 2.6.x where boto now uses AWS v4 signatures by default (with no config option to revert to v2 signatures), which is fine for connections to AWS, but we need to ensure other boto users (e.g openstack APIs like nova ec2 API) won't be broken by this (openstack-heat has been updated to handle v4 signatures already upstream)
Comment 10 Orion Poplawski 2013-07-25 17:08:46 EDT
Does this mean that python-boto will be moving from EPEL to RHEL for 6.5?
Comment 11 Steven Hardy 2013-07-26 05:46:11 EDT
(In reply to Orion Poplawski from comment #10)
> Does this mean that python-boto will be moving from EPEL to RHEL for 6.5?

python-boto is already in RHEL (rhel-x86_64-server-rh-common-6 channel)
Comment 12 Orion Poplawski 2013-07-26 13:09:11 EDT
Ah, okay - that's why it is still in EPEL6.
Comment 16 Alan Pevec 2013-09-17 14:46:04 EDT

*** This bug has been marked as a duplicate of bug 999080 ***

Note You need to log in before you can comment on or make changes to this bug.