Bug 968255 - MIMEUtilTest fails if performed in wrong timezone (east to UTC)
MIMEUtilTest fails if performed in wrong timezone (east to UTC)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libdap (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 06:18 EDT by Eugene Syromyatnikov
Modified: 2013-05-29 17:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 17:31:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for the TZ-sensitive test (2.17 KB, patch)
2013-05-29 06:19 EDT, Eugene Syromyatnikov
no flags Details | Diff

  None (edit)
Description Eugene Syromyatnikov 2013-05-29 06:18:04 EDT
Description of problem:
Tests in unit-tests/MIMEUtilTest.cc (namely, set_mime_text_test() and rfc822_date_test()) fail if performed in eastern (related to UTC) timezones since mktime()

Version-Release number of selected component (if applicable):
Tested with 3.11.0-2, but quick look at 3.11.3-3 reveals no differences in this part of code.

How reproducible:
Always.

Steps to Reproduce:
1. Set tomezone to UTC+smth (Europe/Moscow is fine).
2. Try to build package.

Actual results:
Tests set_mime_text_test() and rfc822_date_test() fail which fails the build.

Expected results:
Tests set_mime_text_test() and rfc822_date_test() should pass.

Additional info:
Some quick patch (against 3.11.0, but should apply also against 3.11.3 since difference between those two versions of this file is negligible) which should likely solve the problem.
Comment 1 Eugene Syromyatnikov 2013-05-29 06:19:10 EDT
Created attachment 754280 [details]
Patch for the TZ-sensitive test
Comment 2 Orion Poplawski 2013-05-29 17:31:51 EDT
I would suggest sending this to support@opendap.org, they are pretty responsive.  I'm afraid I'm not really interested in maintaining a patch that just fixes a testcase.

Note You need to log in before you can comment on or make changes to this bug.