Bug 968266 - Data can't be restored for an exsisted diy app
Data can't be restored for an exsisted diy app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 06:46 EDT by joycezhang
Modified: 2015-05-14 19:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: devenv_3284
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2013-05-29 06:46:53 EDT
Description of problem:
If trying to restore data to an existed diy app, the data won't be restored.

Version-Release number of selected component (if applicable):
INT(devenv_3281)

How reproducible:
always

Steps to Reproduce:
1.Create a diy app
#rhc app create diy1 diy-0.1
2.Change data in local repo(such as change diy/index.html) and git push
3.Snapshot save 
#rhc snapshot save diy1
4. Change data in local repo again (such as change diy/index.html) and git push
5.Snapshot restore

Actual results:
The data are not restored after snapshot restore finised.

Expected results:
The data should be restored as same as step2.

Additional info:
It works well when restoring data to a new app.
Comment 1 Dan Mace 2013-05-29 09:45:31 EDT
Couldn't reproduce in devenv_3284; I performed the following steps:

1. Created a diy-0.1 app
2. Modified diy/index.html in the app
3. Git push the modification, verify changes
4. rhc snapshot save the app
5. Modified diy/index.html in the app
6. Git push the new modification, verify changes
7. rhc snapshot restore the app
8. Verify the changes from #3 were effective

Please try again in devenv_3284 and let's see if the bug was resolved by a previous commit.
Comment 2 joycezhang 2013-05-30 01:31:51 EDT
It works on latest INT(devenv_3287), move it to verified. Thanks.

Note You need to log in before you can comment on or make changes to this bug.