Bug 968274 - ORACLE env vars are not added after migration for zend-5.6 apps
ORACLE env vars are not added after migration for zend-5.6 apps
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 07:04 EDT by joycezhang
Modified: 2015-05-14 19:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 13:03:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2013-05-29 07:04:51 EDT
Description of problem:
No ORACLE env vars added for zend-5.6 apps after migration.

Version-Release number of selected component (if applicable):
INT(devenv_3281)

How reproducible:
always

Steps to Reproduce:
1. create zend-5.6 apps before INT migration
2. SSH into the zend app and check ORACLE env after INT migrated to devenv_3281

Actual results:
No ORACLE env vars returned.
[zendnew-dmintst1.int.rhcloud.com 519b012b6cec0eae1d000368]\> env|grep ORACLE

Expected results:
ORACLE_BASE and ORACLE_HOME env vars should be shown.
[zend29-dmintst1.int.rhcloud.com 51a59b7603ef6491cc000138]\> env|grep ORACLE
ORACLE_BASE=/var/lib/openshift/51a59b7603ef6491cc000138/zend//oracle
ORACLE_HOME=/var/lib/openshift/51a59b7603ef6491cc000138/zend//oracle


Additional info:
Comment 1 Vojtech Vitek 2013-05-29 13:03:54 EDT
We couldn't reproduce a state where the ORACLE_* variables weren't being created during migration with danmace. It's working on DEVENV with https://github.com/openshift/li/commit/9951537934a3618194cf5b510a2b3681825b197d merged in.

Just to clarify:
- v1 doesn't create any ORACLE_* env vars
- v2 creates ORACLE_* env vars
- v1->v2 migration creates ORACLE_* env vars

Note You need to log in before you can comment on or make changes to this bug.