Bug 9683 - exmh fails to init with glimpse-4.12.5-1
exmh fails to init with glimpse-4.12.5-1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: exmh (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-22 13:15 EST by Mike Wescott
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-06 09:54:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Wescott 2000-02-22 13:15:06 EST
I installed ftp.redhat.com/contrib/libc6/i386/glimpse-4.12.5-1.i386.rpm
to enable the search features of exmh. But exmh fails in Glimpse_Init
(extrasInit.tcl) because "glimpse -V" exits with a 1 status.

Arguably, this is a bug in glimpse and the parsing of the -V option should
end with RETURNMAIN(1) instead of RETURNMAIN(0) (see glimpse src file
main.c). Just as arguably exmh should not care and should merely parse
the output for having reasonable values.

In any case, one or the other ought to be fixed.
Comment 1 Nalin Dahyabhai 2000-03-06 09:54:59 EST
If glimpse is returning an error code despite having executed correctly (which
is the only way exmh has to check if it executed correctly -- there could be
bad data in the output), then this is a glimpse bug, which should probably be
reported to the glimpse mailing list at "glimpse@cs.arizona.edu" or to the
webglimpse developers at <http://webglimpse.net/developers/submit.html>.

Note You need to log in before you can comment on or make changes to this bug.