Bug 968345 - abrt.pth prevents python virtualenv creation
abrt.pth prevents python virtualenv creation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Jiri Moskovcak
Martin Kyral
: ZStream
Depends On: 912540 912672
Blocks: 947775 907449 964123 976874
  Show dependency treegraph
 
Reported: 2013-05-29 09:47 EDT by Jiri Moskovcak
Modified: 2015-02-01 17:55 EST (History)
22 users (show)

See Also:
Fixed In Version: abrt-2.0.8-16.el6_4.1
Doc Type: Bug Fix
Doc Text:
* Previously, attempts to create a Python virtualenv environment using the "--system-site-packages" option resulted in an exception when the site.py() function attempted to load the abrt_exception_handler package. This was caused because Python tried to load the abrt.pth file, in which the abrt_exception_handler module was imported. Since the abrt_exception_handler module was installed under the /usr/lib64 directory and the abrt.pth file was installed under the /usr/lib directory, the site.py() function did not find the required module. This update moves the abrt.pth file to the architecture specific folder, so on 32-bit systems to the /usr/lib/python2.7/site-packages/ directory and on 64-bit systems to the /usr/lib64/python2.7/site-packages/ directory, which corrects this issue.
Story Points: ---
Clone Of: 912672
Environment:
Last Closed: 2013-09-26 06:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 7 Martin Kyral 2013-09-12 11:03:40 EDT
Verified that the abrt.pth file is placed in the proper location, but unable to reproduce => SanityOnly

0 [mkyral@testbox ~]$ rpm -q abrt-addon-python
abrt-addon-python-2.0.8-15.el6.x86_64
0 [mkyral@testbox ~]$ rpm -ql abrt-addon-python
/etc/abrt/plugins/python.conf
/etc/libreport/events.d/python_event.conf
/usr/bin/abrt-action-analyze-python
/usr/lib/python2.6/site-packages/abrt.pth
/usr/lib64/python2.6/site-packages/abrt_exception_handler.py
/usr/lib64/python2.6/site-packages/abrt_exception_handler.pyc
/usr/lib64/python2.6/site-packages/abrt_exception_handler.pyo
/usr/share/man/man1/abrt-action-analyze-python.1.gz
0 [mkyral@testbox ~]$ virtualenv --system-site-packages tst
New python executable in tst/bin/python
Installing Setuptools...................................................................................................................................................................................................................................done.
Installing Pip..........................................................................................................................................................................................................................................................................................................................................done.
0 [mkyral@testbox ~]$ rm -rf tst
0 [mkyral@testbox ~]$ rpm -q abrt-addon-python
abrt-addon-python-2.0.8-16.el6_4.1.x86_64
0 [mkyral@testbox ~]$ rpm -ql abrt-addon-python
/etc/abrt/plugins/python.conf
/etc/libreport/events.d/python_event.conf
/usr/bin/abrt-action-analyze-python
/usr/lib64/python2.6/site-packages/abrt.pth
/usr/lib64/python2.6/site-packages/abrt_exception_handler.py
/usr/lib64/python2.6/site-packages/abrt_exception_handler.pyc
/usr/lib64/python2.6/site-packages/abrt_exception_handler.pyo
/usr/share/man/man1/abrt-action-analyze-python.1.gz
0 [mkyral@testbox ~]$ virtualenv --system-site-packages tst
New python executable in tst/bin/python
Installing Setuptools...................................................................................................................................................................................................................................done.
Installing Pip..........................................................................................................................................................................................................................................................................................................................................done.
0 [mkyral@testbox ~]$
Comment 9 errata-xmlrpc 2013-09-26 06:05:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1289.html

Note You need to log in before you can comment on or make changes to this bug.