Bug 968355 - Packstack has not loaded the 8021q module although vlan network type was chosen
Packstack has not loaded the 8021q module although vlan network type was chosen
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 4.0
Assigned To: Terry Wilson
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 10:13 EDT by Rami Vaknin
Modified: 2016-04-26 12:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 14:37:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-05-29 10:13:47 EDT
Version:
Grizzly on RHEL6.4, OpenStack Networking with namespace support (kernel-2.6.32-358.el6.x86_64).

Description:
I've installed the env with packstack and configured it to work with vlan network type over OVS.
CONFIG_QUANTUM_INSTALL=y
CONFIG_QUANTUM_L2_PLUGIN=openvswitch
CONFIG_QUANTUM_OVS_TENANT_NETWORK_TYPE=vlan

This type of tenant network requires the 8021q kernel module to be loaded on all compute l3 nodes, however it was not loaded by packstack installation.

It can be loaded by:
/sbin/modprobe 8021q
echo "modprobe 8021q" >> /etc/modules
Comment 1 Terry Wilson 2013-05-30 18:37:18 EDT
Has the lack of the kernel module being loaded actually caused an issue, or is this something that you expect to be needed yet haven't yet run into any specific bugs as a result of it not being loaded? To my knowledge, I haven't ever had to load this module when using quantum/openvswitch. Is it normally required? Or is that just for linuxbridge?
Comment 2 Rami Vaknin 2013-06-03 02:59:35 EDT
I haven't run all our tests yet so I can't tell whether the lack of this module caused an issue, I just know that it was an installation step prior to OpenStack Networking support in packstack.

In addition, I see that this module is not part of my kernel, it's only compiled as kernel module, are you sure that all the 8021q features work natively without the need to load this kernel module?

# grep 8021Q /boot/config-`uname -r`
CONFIG_VLAN_8021Q=m
CONFIG_VLAN_8021Q_GVRP=y
Comment 3 Terry Wilson 2013-06-20 16:33:35 EDT
I'm pretty sure as I've never enabled it and have never seen anyone actually manually enabling it for using quantum/OVS. From what I can tell, the only reason you would need it when using OVS is if you were using brctl-compatibility. My recommendation would be to table this bug, until we actually find a problem that is being caused by this.
Comment 4 Terry Wilson 2013-06-28 14:37:44 EDT
I'm going to go ahead and close this as NOTABUG since it doesn't seem to cause any problems. If you run into an issue, feel free to re-open it.

Note You need to log in before you can comment on or make changes to this bug.