Bug 968366 - Engine installs successfully, web administration portal does not start
Engine installs successfully, web administration portal does not start
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Juan Hernández
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 10:35 EDT by Bob McCarthy
Modified: 2013-08-08 03:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 03:55:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of ovirt engine (47.65 KB, text/plain)
2013-05-29 10:35 EDT, Bob McCarthy
no flags Details

  None (edit)
Description Bob McCarthy 2013-05-29 10:35:26 EDT
Created attachment 754425 [details]
Log of ovirt engine

Description of problem: Web administration portal fails to start


Version-Release number of selected component (if applicable): Ovirt nightly 3.3.0-0.2


How reproducible: Every time


Steps to Reproduce:
1. Start Ovirt-engine
2. open browser
3. try to connect to administration portal

Actual results: blank page


Expected results: Admin portal


Additional info: Error in jboss
Comment 1 Juan Hernández 2013-05-30 04:10:10 EDT
According to the log the engine is not starting correctly because one of the modules is missing a .jar file. The module file that is failing is /var/tmp/ovirt-engine/modules/org/apache/james/mime4j/main/module.xml. This is a symlink created by the engine during startup wich should poit to /usr/share/jboss-as/modules/org/apache/james/mime4j/main/module.xml. Can you check that? The content of that file as installed by the jboss-as RPM should be this:

<?xml version="1.0" encoding="UTF-8"?>

<module xmlns="urn:jboss:module:1.1" name="org.apache.james.mime4j">
    <properties>
        <property name="jboss.api" value="private"/>
    </properties>

    <resources>
        <resource-root path="core.jar"/>
        <resource-root path="dom.jar"/>
        <resource-root path="storage.jar"/>
        <!-- Insert resources here -->
    </resources>

    <dependencies>
        <module name="javax.api"/>
        <module name="org.apache.commons.logging"/>
    </dependencies>
</module>

As you can see this module references the .jar files core.jar, dom.jar and storage.jar, that should be in the same directory, but it looks that in you case the module references apache-mime4j-core.jar. This file name doesn't match any version of JBoss that I am aware off. I would suggest to remove completely the jboss-as installation, at least the module



# rm -rf /usr/share/jboss-as/modules
# yum reinstall jboss-as

Then restart the engine and try again.

If you still have problems please report the specific version of the jboss-as package that you are using and the content of the /usr/share/jboss-as/modules/org/apache/james/mime4j/main/module.xml file and the /usr/share/jboss-as/modules/org/apache/james/mime4j/main directory:

# ls -l /usr/share/jboss-as/modules/org/apache/james/mime4j/main
# cat /usr/share/jboss-as/modules/org/apache/james/mime4j/main/module.xml
Comment 2 Juan Hernández 2013-08-08 03:55:13 EDT
I think that this issue was solved in jboss-as-7.1.1-20. I'm closing the bug. If it isn't solved please reopen.

Note You need to log in before you can comment on or make changes to this bug.