Bug 968368 - SCL re-defines %_sharedstatedir macro in a wrong way
SCL re-defines %_sharedstatedir macro in a wrong way
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 10:38 EDT by Honza Horak
Modified: 2014-01-10 02:42 EST (History)
4 users (show)

See Also:
Fixed In Version: scl-utils-20131017-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:19:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2013-05-29 10:38:09 EDT
Description of problem:
SCL and core-system values of %_sharedstatedir RPM macros are suspiciously different:

$ grep _sharedstatedir /etc/rpm/*
/etc/rpm/macros.scl:%global _root_sharedstatedir    %{_prefix}/com
/etc/rpm/macros.scl:%global _sharedstatedir        %{_prefix}/com

$ rpm -E '%{_sharedstatedir}'
/var/lib

It results in unexpected value of %{_sharedstatedir} in SCL package:

/opt/rh/<vendor>/<collection>/root/usr/com

instead of

/opt/rh/<vendor>/<collection>/root/var/lib

Version-Release number of selected component (if applicable):
scl-utils-20121110-2.fc19.x86_64
Comment 1 Jan Zeleny 2013-06-04 04:52:45 EDT
Adding Jindrich to CC. Jindro, is the difference intended for some reason or is this a bug?
Comment 2 Jindrich Novy 2013-06-04 11:07:13 EDT
The %_sharedstatedir default comes from /usr/lib/rpm/macros. It is a (very obsolete) default value. Feel free to update/redefine it as needed.
Comment 3 Fedora Update System 2013-10-16 03:42:26 EDT
scl-utils-20131015-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scl-utils-20131015-1.fc20
Comment 4 Fedora Update System 2013-10-16 03:43:06 EDT
scl-utils-20131015-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scl-utils-20131015-1.fc19
Comment 5 Jan Zeleny 2013-10-16 06:32:35 EDT
The "updated update" is here:
https://admin.fedoraproject.org/updates/scl-utils-20131016-1.fc19
Comment 6 Jan Zeleny 2013-10-17 10:22:29 EDT
While testing on real-life collections I found one unrelated issue in scl-utils, a new update has been issued:

https://admin.fedoraproject.org/updates/scl-utils-20131017-1.fc19
Comment 7 Fedora Update System 2013-10-17 16:32:27 EDT
Package scl-utils-20131017-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scl-utils-20131017-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19205/scl-utils-20131017-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-11-10 02:19:14 EST
scl-utils-20131017-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-01-10 02:42:12 EST
scl-utils-20131017-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.