Bug 968521 - loginctl not locking sessions
loginctl not locking sessions
Status: CLOSED DUPLICATE of bug 966904
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 15:55 EDT by Dale Macartney
Modified: 2013-06-21 06:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 06:54:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Macartney 2013-05-29 15:55:57 EDT
Description of problem:
loginctl does not lock sessions with running "loginctl lock-sessions" as root or with sudo

Version-Release number of selected component (if applicable):

libgudev1.i686 0:201-2.fc18.7          
libgudev1.x86_64 0:201-2.fc18.7          
systemd.x86_64 0:201-2.fc18.7          
systemd-libs.i686 0:201-2.fc18.7    
systemd-libs.x86_64 0:201-2.fc18.7     
systemd-python.x86_64 0:201-2.fc18.7     
systemd-sysv.x86_64 0:201-2.fc18.7

How reproducible:
Every time

Steps to Reproduce:
1. run yum upgrade on Fedora 18 Desktop system (tested on x86_64 with Gnome3)
2. run "loginctl lock-sessions" as root or with sudo


Actual results:
session does not lock. no error output. 

Expected results:
session should lock to password prompt. 

Additional info:
downgrading to the below version of packages resolves the issue. 

libgudev1.i686 0:195-15.fc18           
libgudev1.x86_64 0:195-15.fc18           
systemd.x86_64 0:195-15.fc18           
systemd-libs.i686 0:195-15.fc18     
systemd-libs.x86_64 0:195-15.fc18      
systemd-python.x86_64 0:195-15.fc18      
systemd-sysv.x86_64 0:195-15.fc18

Note: This is also resolved in Fedora 19 Beta.
Comment 1 Lennart Poettering 2013-06-21 06:54:59 EDT

*** This bug has been marked as a duplicate of bug 966904 ***

Note You need to log in before you can comment on or make changes to this bug.