Bug 968618 - "gcc" package won't install because of conflict with "audit" package
"gcc" package won't install because of conflict with "audit" package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 19:14 EDT by jradick
Modified: 2013-05-30 10:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 10:02:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jradick 2013-05-29 19:14:10 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install x86_64 KDE distro of Fedora 18 (Fedora-18-x86_64-Live-KDE.iso)
2. start "apper" (Software Management) from Kickoff Application Launcher
3. select package "gcc" and click "apply"

Actual results:
 pop-up window says:
    "Two packages provide the same file.
     This is usually due to mixing packages for different software origins."
 click on "Details", get the message
    "Test Transaction Errors: file /usr/lib64/audit from install of
     glibc-2.16-31.fc18.x86_64 conflicts with file from package
     audit-2.2.1-2.fc18.x86_64"

Expected results:
  Successful install of the most basic developer tool
  using the default software management tool using
  default settings, right after a clean install and package update.

Additional info:
  I can't believe any one has bothered to install this as a development
  platform, because I don't see how anyone could get past this.
Comment 1 Bill Nottingham 2013-05-30 09:54:15 EDT
This was fixed in a later audit release for F19, at least. Moving there.
Comment 2 Steve Grubb 2013-05-30 10:02:19 EDT
Yes, its been fixed in 2.3.

Note You need to log in before you can comment on or make changes to this bug.