Bug 968622 - SELinux is preventing /usr/bin/systemctl from 'write' accesses on the sock_file private.
SELinux is preventing /usr/bin/systemctl from 'write' accesses on the sock_fi...
Status: CLOSED DUPLICATE of bug 968610
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8d78f25068c5e8e5bfbf4c02374...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 19:29 EDT by Daniel Demus
Modified: 2013-05-30 07:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 07:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Demus 2013-05-29 19:29:10 EDT
Description of problem:
libreswan has recently replaced openswan
SELinux is preventing /usr/bin/systemctl from 'write' accesses on the sock_file private.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that systemctl should be allowed write access on the private sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemctl /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:ipsec_mgmt_t:s0
Target Context                system_u:object_r:init_var_run_t:s0
Target Objects                private [ sock_file ]
Source                        systemctl
Source Path                   /usr/bin/systemctl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-201-2.fc18.7.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-96.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-30 01:26:07 CEST
Last Seen                     2013-05-30 01:26:07 CEST
Local ID                      db0595c5-ac64-4619-aa47-0ef6adecf044

Raw Audit Messages
type=AVC msg=audit(1369869967.779:414): avc:  denied  { write } for  pid=5113 comm="systemctl" name="private" dev="tmpfs" ino=14639 scontext=system_u:system_r:ipsec_mgmt_t:s0 tcontext=system_u:object_r:init_var_run_t:s0 tclass=sock_file


type=SYSCALL msg=audit(1369869967.779:414): arch=x86_64 syscall=connect success=no exit=EACCES a0=3 a1=7fffd2c153f0 a2=16 a3=7fffd2c15170 items=0 ppid=1277 pid=5113 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=systemctl exe=/usr/bin/systemctl subj=system_u:system_r:ipsec_mgmt_t:s0 key=(null)

Hash: systemctl,ipsec_mgmt_t,init_var_run_t,sock_file,write

audit2allow

#============= ipsec_mgmt_t ==============
allow ipsec_mgmt_t init_var_run_t:sock_file write;

audit2allow -R
require {
	type ipsec_mgmt_t;
}

#============= ipsec_mgmt_t ==============
init_write_pid_socket(ipsec_mgmt_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-30 07:48:05 EDT

*** This bug has been marked as a duplicate of bug 968610 ***

Note You need to log in before you can comment on or make changes to this bug.