Bug 968781 - Correct test methods dependency in EjbMethodInterceptorTestCase
Correct test methods dependency in EjbMethodInterceptorTestCase
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity low
: ER1
: EAP 6.1.1
Assigned To: Chao Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 21:56 EDT by Chao Wang
Modified: 2013-09-16 16:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:26:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1407 Minor Resolved Correct test methods dependency in EjbMethodInterceptorTestCase 2015-12-15 11:58 EST

  None (edit)
Description Chao Wang 2013-05-29 21:56:53 EDT
Description of problem:

org.jboss.as.test.integration.ejb.interceptor.method.EjbMethodInterceptorTestCase failed intermittently due to dependency of test ordering on https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-openJDK7/lastCompletedBuild/jdk=openjdk-1.7.0-local,label_exp=RHEL6%26%26x86_64/testReport/org.jboss.as.test.integration.ejb.interceptor.method/EjbMethodInterceptorTestCase/testMethodLevelInterceptors/

This test assumes testMethodLevelInterceptors() run at first which does not contain variable TopSecretInterceptor.called reset to false at beginning like second test method does. If test run in different order, then it will fail, should isolate this "connection" between test methods.

Version-Release number of selected component (if applicable):

EAP 6.1.1


How reproducible:

Use @InSequence to run testMethodOverloaded() before testMethodLevelInterceptors(), then test will fail.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

No dependency between test order.


Additional info:
Comment 1 JBoss JIRA Server 2013-05-29 21:59:32 EDT
Chao Wang <chaowan@redhat.com> made a comment on jira WFLY-1407

pull request merged
Comment 2 Rostislav Svoboda 2013-06-07 06:14:48 EDT
QA_ACK granted, AS TS fix.
Comment 3 Ondrej Chaloupka 2013-06-19 18:45:48 EDT
Verified on EAP 6.1.1.ER1.
The test ordering should not be problem in this case any more.

Note You need to log in before you can comment on or make changes to this bug.