Bug 968815 - Cannot remove jgroups subsystem from CLI by saying "JBAS014807: Management resource ... not found"
Cannot remove jgroups subsystem from CLI by saying "JBAS014807: Management re...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.1.1
Assigned To: Brian Stansberry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 23:39 EDT by Osamu Nagano
Modified: 2013-09-16 16:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of Red Hat JBoss Enterprise Application Platform 6 a path included in JGroupsSubsystemRemove was formatted without an element to define the server's profile. In a standalone environment this did not cause a problem. In domain mode, however, this oversight caused an error when attempting to remove the JGroups subsystem using the command: [domain@localhost:9999 /] /profile=test/subsystem=jgroups:remove() This command would produce the following error: "JBAS014807: Management resource '[(\"subsystem\" => \"jgroups\")]' not found" This version of Red Hat JBoss Enterprise Application Platform 6 includes the missing profile element in the PathAddress and users are now able to remove the JGroups subsystem using the CLI command above.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:20:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1437 Major Resolved Cannot remove JGroups subsystem from managed domain via CLI 2017-06-09 02:41 EDT

  None (edit)
Description Osamu Nagano 2013-05-29 23:39:59 EDT
Description of problem:
In EAP 6.1 domain mode, try to create a new profile from scratch in CLI.  You can add jgroups subsystem but you cannot remove it with an error message.
In standalone mode and both modes of EAP 6.0.1, you can successfully remove it.


Steps to Reproduce:
1. Start EAP 6.1 in domain mode.  The default domain.xml is sufficient.
2. Connect to the DC by CLI.
3. Execute the following commands in CLI.
--
[domain@localhost:9999 /] /profile=test:add()
[domain@localhost:9999 /] /profile=test/subsystem=jgroups:add(default-stack=udp)
[domain@localhost:9999 /] /profile=test/subsystem=jgroups:remove()
--

Actual results:
{
    "outcome" => "failed",
    "failure-description" => {"domain-failure-description" => "JBAS014807: Management resource '[(\"subsystem\" => \"jgroups\")]' not found"},
    "rolled-back" => true
}

Expected results:
{
    "outcome" => "success",
    "result" => undefined,
    "server-groups" => undefined
}
Comment 2 Brian Stansberry 2013-06-01 11:38:33 EDT
This same problem exists in upstream. There's been some discussion that the patch for https://issues.jboss.org/browse/WFLY-439 fixes this, but it doesn't (and shouldn't, as it's unrelated.)

The problem is in JGroupsSubsystemRemove:

ModelNode removeSubsystem = Util.createOperation(REMOVE, PathAddress.pathAddress(JGroupsExtension.SUBSYSTEM_PATH));
        context.addStep(removeSubsystem, new OriginalSubsystemRemoveHandler(), OperationContext.Stage.MODEL, true);

That PathAddress.pathAddress(JGroupsExtension.SUBSYSTEM_PATH) is incorrect in a managed domain, as it doesn't include the profile element. It's correct in a standalone server.

Easy fix.
Comment 4 Petr Kremensky 2013-06-19 05:08:26 EDT
Verified on EAP 6.1.1 ER1
Comment 5 Scott Mumford 2013-08-19 22:43:38 EDT
Added a draft release note for the 6.1.1 RN document. Please review for technical accuracy and comment on any problems.
Comment 6 Brian Stansberry 2013-08-20 01:37:11 EDT
Looks fine, Scott.

Note You need to log in before you can comment on or make changes to this bug.