Bug 968821 - RFE - We need a way to download an image, so that you can edit and upload the new version
RFE - We need a way to download an image, so that you can edit and upload the...
Status: CLOSED NEXTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 23:54 EDT by Misty Stanley-Jones
Modified: 2014-06-18 03:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 00:48:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2013-05-29 23:54:27 EDT
You can currently replace an image with a new one, but there is no way to actually download the image. Right-clicking on the image preview and downloading it will only get you the preview.

The workaround is to use the REST API, but this is not very user-friendly. As an example: http://skynet.usersys.redhat.com:8080/pressgang-ccms/rest/1/image/get/raw/28
Comment 1 Matthew Casperson 2013-06-03 00:23:48 EDT
Fixed in 201306031422

The View Image button has been modified to open a page with the raw image displayed. From there it can be downloaded (right click and Save Image As...) and manipulated locally.

NOTE:
When QAing bug fixes, please make sure the build you are using is equal to or higher than the build identified above.
Comment 2 Misty Stanley-Jones 2013-06-03 00:30:22 EDT
This doesn't work as expected. I loaded image 28, which is supposed to be an SVG. I clicked the View Image button, right-clicked, did Save As, and was offered to save a JPG.

Also, it seems to use the same image name for everything (index.jpg). Maybe it should name the image the same as the original file name, or that plus the image ID?
Comment 3 Matthew Casperson 2013-06-03 00:38:44 EDT
What is the build ID in the bottom left hand corner? I only uploaded this fix about 30 seconds ago.
Comment 5 Misty Stanley-Jones 2013-06-03 00:45:13 EDT
Build 201305310810

Should I upload and try again? I thought it must be good to go because it had the View Image button.
Comment 6 Misty Stanley-Jones 2013-06-03 00:45:32 EDT
Works.

Note You need to log in before you can comment on or make changes to this bug.