Bug 968840 - [abrt] yum-3.4.3-91.fc19: __init__.py:3351:_groupInstalledData:AttributeError: 'InstalledGroup' object has no attribute 'packages'
[abrt] yum-3.4.3-91.fc19: __init__.py:3351:_groupInstalledData:AttributeError...
Status: CLOSED DUPLICATE of bug 955236
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:55ec1a291bdf3718464d7d14816...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 01:34 EDT by Andy Grover
Modified: 2013-06-03 03:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 03:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.82 KB, text/plain)
2013-05-30 01:34 EDT, Andy Grover
no flags Details
File: core_backtrace (733 bytes, text/plain)
2013-05-30 01:34 EDT, Andy Grover
no flags Details
File: environ (2.25 KB, text/plain)
2013-05-30 01:34 EDT, Andy Grover
no flags Details

  None (edit)
Description Andy Grover 2013-05-30 01:34:46 EDT
Description of problem:
yum groupremove core

Version-Release number of selected component:
yum-3.4.3-91.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /bin/yum groupremove core
executable:     /bin/yum
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
__init__.py:3351:_groupInstalledData:AttributeError: 'InstalledGroup' object has no attribute 'packages'

Traceback (most recent call last):
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 126, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 522, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1047, in doCommand
    return base.removeGroups(extcmds)
  File "/usr/share/yum-cli/cli.py", line 1961, in removeGroups
    txmbrs = self.groupRemove(group.groupid)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3566, in groupRemove
    igroup_data = self._groupInstalledData(thisgroup)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3351, in _groupInstalledData
    for pkg_name in set(group.packages + list(pkg_names)):
AttributeError: 'InstalledGroup' object has no attribute 'packages'

Local variables in innermost frame:
self: <cli.YumBaseCli object at 0xfb91d0>
group: <yum.igroups.InstalledGroup object at 0x10e1350>
ret: {}
pkg_names: set(['rpmfusion-free-release', 'openssh-clients', 'less', 'iputils', 'sudo', 'parted', 'kbd', 'iproute', 'biosdevname', 'selinux-policy-targeted', 'rsyslog', 'curl', 'rpm', 'vim-minimal', 'systemd', 'glibc', 'hostname', 'shadow-utils', 'coreutils', 'bash', 'man-db', 'NetworkManager', 'policycoreutils', 'procps-ng', 'sendmail', 'ncurses', 'authconfig', 'iprutils', 'util-linux', 'cronie', 'basesystem', 'audit', 'dhclient', 'rootfiles', 'setup', 'firewalld', 'e2fsprogs', 'openssh-server', 'initscripts', 'plymouth', 'yum', 'filesystem', 'passwd', 'ppc64-utils'])
Comment 1 Andy Grover 2013-05-30 01:34:52 EDT
Created attachment 754664 [details]
File: backtrace
Comment 2 Andy Grover 2013-05-30 01:34:55 EDT
Created attachment 754665 [details]
File: core_backtrace
Comment 3 Andy Grover 2013-05-30 01:34:59 EDT
Created attachment 754666 [details]
File: environ
Comment 4 Jan Zeleny 2013-06-03 03:12:47 EDT

*** This bug has been marked as a duplicate of bug 955236 ***

Note You need to log in before you can comment on or make changes to this bug.