Bug 968860 - multiarch conflict samba-common
multiarch conflict samba-common
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 02:42 EDT by Andreas Bierfert
Modified: 2014-04-14 05:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-14 05:00:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f (946.47 KB, application/x-bzip)
2014-04-11 04:33 EDT, austinenglish
no flags Details

  None (edit)
Description Andreas Bierfert 2013-05-30 02:42:52 EDT
wine needs samba-winbind-clients for some installations/programs to work correctly. Adding the proper requires to wine samba-winbind-clients x86-32 and x86-64 need to be parallel installed on 64bit systems to support win32 and win64. However this is not possible as samba-common x86-32 and x86-64 conflict:

 file /usr/bin/net from install of samba-common-2:4.0.6-2.fc19.i686 conflicts with file from package samba-common-2:4.0.6-2.fc19.x86_64
  file /usr/bin/pdbedit from install of samba-common-2:4.0.6-2.fc19.i686 conflicts with file from package samba-common-2:4.0.6-2.fc19.x86_64
  file /usr/bin/profiles from install of samba-common-2:4.0.6-2.fc19.i686 conflicts with file from package samba-common-2:4.0.6-2.fc19.x86_64
  file /usr/bin/smbcontrol from install of samba-common-2:4.0.6-2.fc19.i686 conflicts with file from package samba-common-2:4.0.6-2.fc19.x86_64
  file /usr/bin/testparm from install of samba-common-2:4.0.6-2.fc19.i686 conflicts with file from package samba-common-2:4.0.6-2.fc19.x86_64
  file /usr/bin/ntlm_auth from install of samba-winbind-clients-2:4.0.6-2.fc19.i686 conflicts with file from package samba-winbind-clients-2:4.0.6-2.fc19.x86_64
  file /usr/bin/wbinfo from install of samba-winbind-clients-2:4.0.6-2.fc19.i686 conflicts with file from package samba-winbind-clients-2:4.0.6-2.fc19.x86_64
Comment 1 Andreas Schneider 2013-06-03 08:05:39 EDT
What does wine need from the samba-winbind-clients package?
Comment 2 Andreas Bierfert 2013-08-31 10:48:24 EDT
The libnss stuff from %{_libdir}.
Comment 3 Andreas Schneider 2013-09-04 04:49:54 EDT
Can wine load nsswitch modules?
How does it use the modules and for what?
Comment 4 austinenglish 2014-04-11 02:34:33 EDT
(In reply to Andreas Schneider from comment #3)
> Can wine load nsswitch modules?

No.

> How does it use the modules and for what?

ntlm_auth is used by secur32 for wine's SSPI implementation. See:
https://source.winehq.org/git/wine.git/blob/HEAD:/dlls/secur32/dispatcher.c

Still in F20:
[root@localhost ~]# yum install samba-winbind-clients.i686
Loaded plugins: langpacks, refresh-packagekit
No package samba-winbind-clients.i686 available.
Error: Nothing to do

this breaks the secur32 {negotiate,ntlm} tests on Fedora:
negotiate.c:295: Test failed: server returned 80090304, more tests will fail
ntlm.c:857: Test failed: Running the server returned SEC_E_INTERNAL_ERROR, more tests will fail from now.
Comment 5 Alexander Bokovoy 2014-04-11 02:56:39 EDT
secur32 doesn't require 32-bit version of ntlm_auth as it starts it in a separate process.

Why do you insists on using 32-bit version?
Comment 6 austinenglish 2014-04-11 04:33:29 EDT
Created attachment 885287 [details]
strace -f

Because 32-bit wine tries to start a 32-bit ntlm_auth. 64-bit ntlm_auth is installed, but does not work.

strace -f attached.
Comment 7 Andreas Schneider 2014-04-11 05:04:05 EDT
In the strace I can see that it successfully executes the ntlm_auth 64bit version.

grep "^26782" log.txt > 26782.log

You can then check the log and see that it loads 64bit Samba libraries:


26782 open("/usr/lib64/samba/libndr-krb5pac.so.0"


The last line is then:


26782 +++ exited with 0 +++


This is the exit code, 0 = success


So the strace proofs that the 64bit binary works as expected...
Comment 8 Alexander Bokovoy 2014-04-11 05:16:57 EDT
There are also issues in your environment as some configurations you run ntlm_auth in require access to winbindd's pipe and that fails:

26812 lstat("/run/samba/winbindd",  <unfinished ...>
26747 read(32,  <unfinished ...>
26812 <... lstat resumed> 0x7fff4ee4aa50) = -1 ENOENT (No such file or directory)
...
26812 write(1, "could not obtain winbind separat"..., 36) = -1 EPIPE (Broken pipe)
Comment 9 austinenglish 2014-04-11 15:03:47 EDT
(In reply to Alexander Bokovoy from comment #8)
> There are also issues in your environment as some configurations you run
> ntlm_auth in require access to winbindd's pipe and that fails:
> 
> 26812 lstat("/run/samba/winbindd",  <unfinished ...>
> 26747 read(32,  <unfinished ...>
> 26812 <... lstat resumed> 0x7fff4ee4aa50) = -1 ENOENT (No such file or
> directory)
> ...
> 26812 write(1, "could not obtain winbind separat"..., 36) = -1 EPIPE (Broken
> pipe)

You're right, it looks like wine isn't compatible with samba4 (the error for missing ntlm_auth is very similar, my mistake).

I filed https://bugs.winehq.org/show_bug.cgi?id=35965 for that with wine's bugzilla.
Comment 10 Andreas Schneider 2014-04-14 05:00:23 EDT
Thanks for the information. I'm closing this bug now.

Note You need to log in before you can comment on or make changes to this bug.