This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 968904 - vmcore save path name: TIMEZONE is not right
vmcore save path name: TIMEZONE is not right
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
19
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: WANG Chao
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 05:03 EDT by Dave Young
Modified: 2013-08-05 03:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.4-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 03:22:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Young 2013-05-30 05:03:59 EDT
Description of problem:

Kdump captured vmcore dir format is like this
127.0.0.1-2013.05.30-08:45:10

But the actual time should be 13:45:10, there's 8 hours shift, this is because  UTC +0800 is used in 1st kernel


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Dave Young 2013-07-29 04:12:30 EDT
From Harald:

Hmm, people do not like it :-/

Bug 981617 - please take /etc/adjtime out of the initramfs so it doesn't
override the existing file system version

https://bugzilla.redhat.com/show_bug.cgi?id=981617

The patch will probably been reverted in dracut. We'd better add this logic in kdump code.

Reopen this bug.
Comment 3 WANG Chao 2013-08-01 05:31:41 EDT
Since dracut fix is reverted due to lots of complains, re-implemented in kdump module.

Note You need to log in before you can comment on or make changes to this bug.