Bug 968915 - Anaconda locks user account instead of creating it password-less
Summary: Anaconda locks user account instead of creating it password-less
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-05-30 09:30 UTC by Vojtěch Boček
Modified: 2013-06-12 12:23 UTC (History)
10 users (show)

Fixed In Version: anaconda-19.30.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-12 03:38:50 UTC


Attachments (Terms of Use)
anaconda.log from the installation (22.27 KB, text/plain)
2013-05-30 09:30 UTC, Vojtěch Boček
no flags Details
anaconda.program.log from the installation (53.65 KB, text/plain)
2013-05-30 09:31 UTC, Vojtěch Boček
no flags Details
Kickstart generated by anaconda (678 bytes, text/plain)
2013-05-30 09:33 UTC, Vojtěch Boček
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 963797 None None None Never
Red Hat Bugzilla 964299 None None None Never

Internal Links: 963797 964299

Description Vojtěch Boček 2013-05-30 09:30:46 UTC
Created attachment 754737 [details]
anaconda.log from the installation

Description of problem:
When no root password is set in Anaconda and only Administrator user with no password is created, gnome-initial-setup wants me to create a new user. User previously created in anaconda is locked.

Fix of this bug might be related: https://bugzilla.redhat.com/show_bug.cgi?id=964299

Version-Release number of selected component (if applicable):
anaconda 19.30-1

How reproducible:
100%

Steps to Reproduce:
1. Start F19 installation
2. Do not set root password
3. Create new user, check the "Administrator" box and uncheck "Require password..." box
4. After installation, gnome-initial-setup will tell you to create a new user.

Actual results:
User created by anaconda is locked.

Expected results:
The user should be usable.

Additional info:

Comment 1 Vojtěch Boček 2013-05-30 09:31:22 UTC
Created attachment 754739 [details]
anaconda.program.log from the installation

Comment 2 Vojtěch Boček 2013-05-30 09:33:03 UTC
Created attachment 754742 [details]
Kickstart generated by anaconda

Comment 3 Kamil Páral 2013-05-30 09:44:54 UTC
Reproduced with F19 Beta Live x86_64. I instructed anaconda to create a password-less user account, but the account was locked instead and (therefore) gnome-initial-setup was executed on the first boot and forced me to create yet another user.

Proposing as a blocker. Our criteria are a bit lagging behind, but I think this depicts the spirit:
" After firstboot is completed and on subsequent boots, a graphical install must boot to a log in screen where it is possible to log in to a working desktop as the user created during firstboot. "
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria

Replace "firstboot" with anaconda, since anaconda now can create users as well.

Comment 4 Adam Williamson 2013-05-30 17:03:19 UTC
Discussed at 2013-05-30 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . Accepted as a blocker per criterion cited in c#3: esp. on the KDE path you could wind up being unable to log in with this bug.

Comment 5 Fedora Update System 2013-06-06 18:37:45 UTC
anaconda-19.30.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.3-1.fc19

Comment 6 Kamil Páral 2013-06-07 11:38:17 UTC
Verified fixed with anaconda-19.30.3-1.

Comment 7 Fedora Update System 2013-06-12 03:38:50 UTC
anaconda-19.30.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.