Bug 968955 - "Update folders.." dialog should not appear on every login
"Update folders.." dialog should not appear on every login
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xdg-user-dirs-gtk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 07:11 EDT by Vojtěch Boček
Modified: 2013-06-07 00:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: xdg-user-dirs-gtk-0.10-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 00:31:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtěch Boček 2013-05-30 07:11:10 EDT
Description of problem:
After language change, "Update standard folders..." dialog appears. If I don't check "Don't ask me this again" and click "Keep old names", it will ask me on next login again.
If I check "Don't ask me this again" and click "Keep old names", this dialog will not appear after next language change.

Version-Release number of selected component (if applicable):
xdg-user-dirs-0.14-4.fc19.x86_64
xdg-user-dirs-gtk-0.10-1.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Change language on your user and relog
2. In "Update standard folders..." dialog, click "Keep old names"
3. Relog again
4. "Update standard folders..." dialog will appear again
5. Check "Don't ask me this again" and click "Keep old names".
6. Change your language to some third language which should result in "Update standard folders.." dialog
7. Relog
8. "Update standard folders.." will not appear

Actual results:
"Don't ask me this again" completely disables this dialog window.

Expected results:
I think there are two options:
1) "Don't ask me this again" completely disables "Update standard folders..." dialog, but it appears only once after language change, not on every login if "Don't ask me this again" is not checked.
2) "Don't ask me this again" disables the dialog only for current language.

I think 2) is better.
Comment 1 Kamil Páral 2013-05-30 07:28:38 EDT
Reproduced, and it is a regression. This dialog used to appear only once after each language change, and therefore ticking the checkbox didn't use to be necessary.
Comment 2 Fedora Update System 2013-05-30 20:42:26 EDT
xdg-user-dirs-gtk-0.10-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xdg-user-dirs-gtk-0.10-2.fc19
Comment 3 Matthias Clasen 2013-05-30 20:45:07 EDT
I disagree with the complaint here - the dialog should reappear at the next login, until you check the 'don't ask again' checkbox. And I can't see any changes in the recent past that would explain why this should have behaved differently in the past. There was still a bug here though, and i've fixed that: checking that checkbox was disabling the functionality permanently, which was not intended. The update makes it so that the dialog will come back if you change the language again, even if you checked 'don't ask again' before.
Comment 4 Vojtěch Boček 2013-05-31 03:54:33 EDT
The fix works as intended and I think it is better to ask on every login until "don't ask" is checked, thank you.
Comment 5 Fedora Update System 2013-05-31 14:07:50 EDT
Package xdg-user-dirs-gtk-0.10-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xdg-user-dirs-gtk-0.10-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9718/xdg-user-dirs-gtk-0.10-2.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-06-07 00:31:47 EDT
xdg-user-dirs-gtk-0.10-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.