This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 968960 - "ProxyErrorOverride On" does not work if used with mod_proxy_ajp module
"ProxyErrorOverride On" does not work if used with mod_proxy_ajp module
Status: CLOSED WONTFIX
Product: JBoss Enterprise Web Server 1
Classification: JBoss
Component: httpd22 (Show other bugs)
EWS 1.0.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Weinan Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 07:26 EDT by Dasharath Masirkar
Modified: 2013-05-30 09:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 09:56:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 694939 None None None Never

  None (edit)
Description Dasharath Masirkar 2013-05-30 07:26:59 EDT
Description of problem:

"ProxyErrorOverride On" does not work if used with mod_proxy_ajp module.

[ Config Snippet ]

ProxyPass /app/  ajp://127.0.0.1:8009/app/
ProxyErrorOverride On
ErrorDocument 404  /error/404.html

When I access a 404 URL in the /app context, which is proxied with AJP, I get a 404 page from JBoss EAP. Accessing 404 URLs via non-proxied content works as intended, as defined in "ErrorDocument".

Version-Release number of selected component (if applicable):

JBoss EWS 1.0.2 httpd-2.2.17


How reproducible:

Everytime.


Steps to Reproduce:

1. Define "ErrorDocument"
2. Enable "ProxyErrorOverride"
3. Access 404 URL via definied "ProxyPass" context
  

Actual results:

404 error from backend (proxied) server


Expected results:

404 error as defined in "ErrorDocument" via Apache


Additional info:
There is existing [Bug 694939](https://bugzilla.redhat.com/show_bug.cgi?id=694939) with Apache httpd provided with RHEL6, which got fixed in Apache httpd rpm provided with RHEL 6.2
Comment 1 Weinan Li 2013-05-30 09:56:48 EDT
We just provide CVE fixes with high priorities for EWS 1.x as it's enters the maintenance lifecycle.

Note You need to log in before you can comment on or make changes to this bug.