This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 968984 - Snowdrop installation process has changed for EAP 6.1.0
Snowdrop installation process has changed for EAP 6.1.0
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: doc-Snowdrop-User-Guide (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 2.3.0
Assigned To: Sneha
Tomas Repel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 08:19 EDT by Tomas Repel
Modified: 2014-11-09 18:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:34:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2013-05-30 08:19:47 EDT
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2.2/html/Snowdrop_User_Guide/ch02s04s02.html

(note this is link for WFK 2.2 because the WFK 2.3 is not available yet)

Section Number and Name: 
2.4.2. Installation on JBoss Enterprise Application Platform 6

Describe the issue: 
Snowdrop installation process has changed for EAP 6.1.0 compared to EAP 6.0.1. The location has changed, it is not `$JBOSS_HOME/modules/' anymore, for EAP 6.1.0 it is `$JBOSS_HOME/modules/system/layers/base'.

Suggestions for improvement: 
Change that particular sentence to something like this:
`Create the subsystem and Spring modules in JBoss AS7 by copying the contents of the module-deployer directory and one of the module-spring-2.5/, module-spring-3/ or module-spring-3.2/ directories in the $JBOSS_HOME/modules/system/layers/base directory of your JBoss Application Server installation.'
Comment 1 Marek Schmidt 2013-05-30 12:01:13 EDT
Are you sure it belongs to the base layer?
Comment 2 Tomas Repel 2013-05-31 03:38:54 EDT
Not completely, but if you install it there, it works. I searched the documentation for the guidance, I found this:

https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Administration_and_Configuration_Guide/Install_a_Global_Valve.html

As far as I understand it, the static modules should be copied to $JBOSS_HOME/modules/system/layers/base for EAP 6.1.0.
Comment 3 Marek Schmidt 2013-05-31 05:47:00 EDT
Hm, the snowdrop installer also seems to be putting this into /modules/system/layers/base so I guess it's OK

https://github.com/TejasM/snowdrop-install/blob/master/pom.xml#L132
Comment 4 Sneha 2013-05-31 08:39:29 EDT
In reply to the description:

Please note, all the WKF 2.3 guides are available at http://documentation-devel.engineering.redhat.com/docs/en-US/index.html#Red_Hat_JBoss_Web_Framework_Kit

Note the change from "JBoss_Web_Framework_Kit" to "Red_Hat_JBoss_Web_Framework_Kit"
Comment 7 Tomas Repel 2013-06-26 06:19:12 EDT
Verified in WFK 2.3.0.CR1.

Note You need to log in before you can comment on or make changes to this bug.