Bug 968994 - Scaling fails when hot_deploy marker is present
Scaling fails when hot_deploy marker is present
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On: 963490
Blocks: 969007
  Show dependency treegraph
 
Reported: 2013-05-30 08:38 EDT by Matt Hicks
Modified: 2013-06-11 00:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 963490
: 969007 (view as bug list)
Environment:
Last Closed: 2013-06-11 00:00:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Hicks 2013-05-30 08:38:20 EDT
Description of problem:
When hot_deploy is present, new scaled gears are never started.

Version-Release number of selected component (if applicable):
Codebase as of 3/18/2013

How reproducible:
Consistent (tested with JBoss EAP and PHP)

Steps to Reproduce:
1. Spin up a development instance (assuming dev.rhcloud.com below)

2. Create a scaled JBoss EAP application named scale:
  rhc app-create scale jbosseap -s

3. Enable hot_deploy
  cd scale; touch .openshift/markers/hot_deploy
  git add .; git commit -a -m "Adding hot deploy";
  git push

4. Scale the application to 3 gears
  rhc cartridge-scale jbosseap --app scale --min 3 --max 6

Actual results:
The new gears do not have JBoss started on them.

Expected results:
The new gears should be started and serving traffic

Additional info:
Snip from the /var/log/openshift/platform.log (notice the 'not starting cartridge jbosseap...):

...
+ ssh 146678179485050841595904@10.152.180.46 'gear remotedeploy --init --hot-deploy'
Deploying JBoss
Not starting cartridge jbosseap because hot deploy is enabled

Exit code: 0
...

This behavior is consistent with the PHP cartridge as well:

1. Spin up a development instance (assuming dev.rhcloud.com below)

2. Create a scaled JBoss EAP application named scale:
  rhc app-create scalephp php-5.3 -s

3. Enable hot_deploy
  cd scalephp; touch .openshift/markers/hot_deploy
  git add .; git commit -a -m "Adding hot deploy";
  git push

4. Scale the application to 3 gears
  rhc cartridge-scale php-5.3 --app scalephp --min 3 --max 6
Comment 2 openshift-github-bot 2013-05-30 13:12:51 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/89a24801f33289fca52515bc3768311a59e393c3
Bug 968994: Fix hot deploy during initial scaled gear deployment

Don't respect the hot_deploy marker when peforming initial deployment of
a newly created scaled gear; these gears are not pre-initialized by the
platform.
Comment 4 Meng Bo 2013-05-31 05:12:44 EDT
Checked this issue on devenv_3296 and devenv-stage_354 with all the web cartridges.

Add hot_deploy marker to the app, then set the min gear of the app to 3.
Check the /haproxy-status/ all the gears listed.
SSH login to the scaled-up gears, service running.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.