Bug 969017 - Do not allow to create C/C++ project
Do not allow to create C/C++ project
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 09:30 EDT by peter.senna
Modified: 2014-01-12 19:28 EST (History)
6 users (show)

See Also:
Fixed In Version: eclipse-4.3.0-0.60.git7bf397.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of missing Wizards (72.46 KB, image/png)
2013-05-30 09:30 EDT, peter.senna
no flags Details
log.out (821.12 KB, text/plain)
2013-05-30 16:22 EDT, peter.senna
no flags Details
Comment (176.69 KB, text/plain)
2013-05-30 14:32 EDT, peter.senna
no flags Details

  None (edit)
Description peter.senna 2013-05-30 09:30:08 EDT
Created attachment 754867 [details]
Screenshot of missing Wizards

Description of problem: Do not allow to create C/C++ project


Version-Release number of selected component (if applicable):
eclipse-cdt.x86_64 1:8.2.0-0.6.m7.fc19 

How reproducible:


Steps to Reproduce:
1. yum install eclipse-cdt eclipse-cdt-parsers eclipse-cdt-sdk eclipse-mylyn-context-cdt
2. start Eclipse
3. Try to create a new C/C++ project

Actual results:
There is no Wizard for C/C++ projects

Expected results:
Being able to use the Wizard for creating C/C++ projects

Additional info:
Comment 1 Jeff Johnston 2013-05-30 12:32:20 EDT
(In reply to peter.senna from comment #0)

What has happened is that some dependency of the CDT is not being met and causing it not to load or an exception has occurred within the CDT.

Can you look at the Error Log and add it as an attachment please.  Help -> About Eclipse SDK -> Installation Details -> Configuration -> Show Error Log

If you go to Help -> About Eclipse SDK -> Installation Details -> Plug-ins you will see a list of loaded plugins.  Look for the ones with CDT in them and report that here.  If there is a dependency issue, there will be missing CDT plug-ins.
Comment 2 peter.senna 2013-05-30 14:32:09 EDT
Created attachment 915719 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 3 Jeff Johnston 2013-05-30 14:48:27 EDT
Hmm, not being able to see the error log is not good.  Your CDT plug-ins are not loaded from the data above.

Can you start your Eclipse with -clean -consoleLog -debug options and then add the results here?  If you redirect output to a file, then it will be easy to attach the results here.
Comment 4 Roland Grunberg 2013-05-30 15:02:41 EDT
Just a small amendment to Jeff's Comment #3 : Make sure to create a file called '.options' with the following content :

org.eclipse.equinox.p2.core/debug=true
org.eclipse.equinox.p2.core/reconciler=true

in the same location that you run the eclipse command.
Comment 5 peter.senna 2013-05-30 16:22:35 EDT
Created attachment 755037 [details]
log.out
Comment 6 peter.senna 2013-05-30 16:24:12 EDT
$ cd /tmp

$ cat .options
org.eclipse.equinox.p2.core/debug=true
org.eclipse.equinox.p2.core/reconciler=true

$ /usr/lib64/eclipse/eclipse -clean -consoleLog -debug &> log.out

log.out is attached.
Comment 7 Roland Grunberg 2013-05-30 17:25:39 EDT
I have an F19 VM that's up to date and seems to have no issues with the Eclipse CDT. I have a list of the installed rpms here : http://rgrunber.fedorapeople.org/rpms19.txt Is there perhaps some underyling package that isn't updated and could be causing this ?

Also if you run 'eclipse -nosplash -noexit -console' , and run 'ss cdt', you should see the cdt bundles listed. Do any of them have a state of 'INSTALLED' listed ? Also what do you see when you run 'ss -s INSTALLED' ?
Comment 8 peter.senna 2013-05-31 04:22:16 EDT
I have installed Fedora from the Beta live DVD.

$ eclipse -nosplash -noexit -console
____________________________
Welcome to Apache Felix Gogo

g! ss cdt
"Framework is launched."


id	State       Bundle
g!
Comment 9 peter.senna 2013-05-31 08:16:25 EDT
After doing yum update today, it was magically fixed. Thank you very much.
Comment 10 Roland Grunberg 2013-05-31 14:07:02 EDT
It looks like the reconciler was dropping the cdt bundles for some reason, and so they were not even showing up in the osgi runtime. Eclipse Kepler RC2 is now in updates-testing so perhaps this solved the issue. I'm going to mark this as CLOSED (UPSTREAM) given that the resolution was to update to a newer release candidate.

If this bug appears again on f19 for a newer version of Eclipse CDT, then we can reopen, and investigate further.
Comment 11 peter.senna 2013-06-01 09:24:07 EDT
The problem returned when updated to eclipse-cdt.x86_64 1:8.2.0-0.7.rc2.fc19, eclipse-cdt-sdk.x86_64 1:8.2.0-0.7.rc2.fc19
Comment 12 Krzysztof Daniel 2013-06-03 11:06:44 EDT
This may be an issue with the reconciler itself. Unless it is fully diagnosed, please use this workaround:

sudo touch /usr/lib64/eclipse/configuration/config.ini

it should force your Eclipse to reinstall all plugins.
Comment 13 peter.senna 2013-06-03 11:25:22 EDT
Krzysztof Daniel, this is not a good solution, at all. Even if fixed the issue I reported.

I'm using Fedora and yum as package source. I do not want that Eclipse download software from Eclipse website. I only trust Fedora rpm packages as I understand how it works.

The Migration Wizard has started, took some minutes to finish and downloaded something from Eclipse website. The problem may still exist even if it is working for me again.

How to revert so my Eclipse will not download updates / modules / anything from Eclipse site?

I don't agree that this is a solution. I can remove Eclipse from my machine and remove all files you ask me to. Then only install packages from yum. Please tell me how.

This do not look as a solution for me.
Comment 14 Krzysztof Daniel 2013-06-03 11:48:38 EDT
Peter,

Sorry for those problems. Here is more precise instruction:
1. Touch the config.ini file. This will drop again all downloaded plugins.
2. Cancel the reinstallation wizard (if you don't want to reinstall any upstream bundles) or select only those you really need. At your will.
Comment 15 Krzysztof Daniel 2013-06-03 11:49:13 EDT
I know it's not a solution, just a workaround that allows you to work with Eclipse while I'm investigating this issue.
Comment 16 Fedora Update System 2013-06-06 07:09:29 EDT
eclipse-4.3.0-0.60.git7bf397.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/eclipse-4.3.0-0.60.git7bf397.fc19
Comment 17 Fedora Update System 2013-06-06 13:31:46 EDT
Package eclipse-4.3.0-0.60.git7bf397.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.3.0-0.60.git7bf397.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10208/eclipse-4.3.0-0.60.git7bf397.fc19
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-06-07 23:42:58 EDT
eclipse-4.3.0-0.60.git7bf397.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.