Bug 969031 - os cant bring bridge up after installation
os cant bring bridge up after installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 10:03 EDT by Xiaoqing Wei
Modified: 2016-11-25 08:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 03:49:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart (6.36 KB, text/plain)
2013-05-30 10:03 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-05-30 10:03:56 EDT
Created attachment 754871 [details]
kickstart

Description of problem:

os cant bring bridge up after installation

Version-Release number of selected component (if applicable):

initscripts-9.46-1.el7.x86_64
all components from 20130522.0

How reproducible:

5/5

Steps to Reproduce:
1.install a host w/ a kickstart, attached.
2.
3.

Actual results:
host didn't have network access after installation

Expected results:
host network should functional

Additional info:
Comment 1 Lukáš Nykrýn 2013-05-30 10:13:15 EDT
Can you please attach the output of systemctl status network.service?
Comment 3 Xiaoqing Wei 2013-05-30 22:01:28 EDT
(In reply to Lukáš Nykrýn from comment #1)
> Can you please attach the output of systemctl status network.service?

[root@localhost staf-kvm-devel]# systemctl status network.service
network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network)
   Active: active (exited) since Thu 2013-05-30 17:00:28 CST; 17h ago
Comment 4 Lukáš Nykrýn 2013-05-31 03:13:48 EDT
I was more interested in lines which can be below these, can you try to restart network and post here the output again and also "journalctl -u network.service
"?
Comment 5 Xiaoqing Wei 2013-05-31 03:53:23 EDT
(In reply to Lukáš Nykrýn from comment #4)
> I was more interested in lines which can be below these, can you try to
> restart network and post here the output again and also "journalctl -u
> network.service
> "?

[root@dhcp-10-30 ~]# systemctl restart network.service
[root@dhcp-10-30 ~]# journalctl -u network.service
-- Logs begin at Thu 2013-05-30 21:29:51 CST, end at Fri 2013-05-31 15:52:41 CST. --
May 30 21:30:02 dhcp-10-30.nay.redhat.com systemd[1]: Starting LSB: Bring up/down networking...
May 30 21:30:02 dhcp-10-30.nay.redhat.com systemd[1]: Started LSB: Bring up/down networking.
May 31 10:20:08 dhcp-10-30.nay.redhat.com systemd[1]: Stopping LSB: Bring up/down networking...
May 31 10:20:08 dhcp-10-30.nay.redhat.com systemd[1]: Stopped LSB: Bring up/down networking.
-- Reboot --
May 31 10:22:02 dhcp-10-30.nay.redhat.com systemd[1]: Starting LSB: Bring up/down networking...
May 31 10:22:02 dhcp-10-30.nay.redhat.com systemd[1]: Started LSB: Bring up/down networking.
May 31 10:38:44 dhcp-10-30.nay.redhat.com systemd[1]: Stopping LSB: Bring up/down networking...
May 31 10:38:44 dhcp-10-30.nay.redhat.com systemd[1]: Stopped LSB: Bring up/down networking.
-- Reboot --
May 31 15:52:41 dhcp-10-30.nay.redhat.com systemd[1]: Stopping LSB: Bring up/down networking...
May 31 15:52:41 dhcp-10-30.nay.redhat.com systemd[1]: Starting LSB: Bring up/down networking...
May 31 15:52:41 dhcp-10-30.nay.redhat.com systemd[1]: Started LSB: Bring up/down networking.
Comment 6 Lukáš Nykrýn 2013-07-11 10:11:31 EDT
Sorry for a delay. I still can't see where the issue might be.
Please attach sour configuration files and try:
[root@notas system]# export SYSTEMCTL_SKIP_REDIRECT=1
[root@notas system]# /etc/init.d/network restart
Comment 7 Xiaoqing Wei 2013-07-12 03:20:26 EDT
Alright, looks this issue doesn't exist now, 

initscripts-9.47-1.el7.x86_64
systemd-204-9.el7.1.x86_64

[root@dhcp-10-30 ~]# systemctl status network.service
network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network)
   Active: active (running) since Fri 2013-07-12 15:10:13 CST; 4min 58s ago
  Process: 578 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=0/SUCCESS)
   CGroup: name=systemd:/system/network.service

now the bridge would up and running after os installation.




[root@dhcp-10-30 network-scripts]# cat ifcfg-br0 ifcfg-eth0 
DEVICE=switch
BOOTPROTO=dhcp
ONBOOT=yes
DELAY=0
TYPE=Bridge
# Generated by parse-kickstart
IPV6INIT=yes
DEVICE=eth0
ONBOOT=yes
UUID=ee4931a5-c78a-467a-9405-2260ea674dc4
HWADDR=E8:39:35:52:93:D0
TYPE=Ethernet
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME="System eth0"
BRIDGE=switch
Comment 8 Lukáš Nykrýn 2013-07-12 03:49:51 EDT
So I will close this as a current release, if the issue reappears please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.