Bug 969032 - IOError: [Errno 9] Bad file descriptor
IOError: [Errno 9] Bad file descriptor
Status: CLOSED DUPLICATE of bug 963267
Product: Fedora
Classification: Fedora
Component: babel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
abrt_hash:493c23b6b9307a9136939428691...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 10:05 EDT by Alexey Derlaft
Modified: 2013-10-02 14:43 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 14:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (262.94 KB, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: anaconda.log (2.25 KB, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: backtrace (1.18 KB, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: environ (760 bytes, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: ifcfg.log (494 bytes, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: lsblk_output (2.33 KB, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: nmcli_dev_list (3.85 KB, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: packaging.log (13.39 KB, text/plain)
2013-05-30 10:05 EDT, Alexey Derlaft
no flags Details
File: program.log (39.62 KB, text/plain)
2013-05-30 10:06 EDT, Alexey Derlaft
no flags Details
File: storage.log (91.01 KB, text/plain)
2013-05-30 10:06 EDT, Alexey Derlaft
no flags Details
File: syslog (116.70 KB, text/plain)
2013-05-30 10:06 EDT, Alexey Derlaft
no flags Details

  None (edit)
Description Alexey Derlaft 2013-05-30 10:05:11 EDT
Description of problem:
1) download fedora 19 netinst
2) burn it to usb flash ising dd
3) load into it and see how anaconda crashes
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/babel/localedata.py", line 111, in load
    fileobj.close()
  File "/usr/lib/python2.7/site-packages/babel/localedata.py", line 101, in load
    data = load(parent).copy()
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 231, in _data
    self.__data = localedata.LocaleDataDict(localedata.load(str(self)))
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 293, in languages
    return self._data['languages']
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 250, in get_display_name
    retval = locale.languages.get(self.language)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/localization.py", line 92, in display_name
    display_name = self._localedata.display_name or self.english_name
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 174, in initialize
    self._addLanguage(store, trans.display_name,
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 367, in run
    self._currentAction.initialize()
  File "/sbin/anaconda", line 1085, in <module>
    anaconda._intf.run()
IOError: [Errno 9] Bad file descriptor

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/sbin/anaconda", line 1085, in <module>
    anaconda._intf.run()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 367, in run
    self._currentAction.initialize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 174, in initialize
    self._addLanguage(store, trans.display_name,
  File "/usr/lib64/python2.7/site-packages/pyanaconda/localization.py", line 92, in display_name
    display_name = self._localedata.display_name or self.english_name
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 250, in get_display_name
    retval = locale.languages.get(self.language)
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 293, in languages
    return self._data['languages']
  File "/usr/lib/python2.7/site-packages/babel/core.py", line 231, in _data
    self.__data = localedata.LocaleDataDict(localedata.load(str(self)))
  File "/usr/lib/python2.7/site-packages/babel/localedata.py", line 101, in load
    data = load(parent).copy()
  File "/usr/lib/python2.7/site-packages/babel/localedata.py", line 111, in load
    fileobj.close()
IOError: [Errno 9] Bad file descriptor
Comment 1 Alexey Derlaft 2013-05-30 10:05:22 EDT
Created attachment 754872 [details]
File: anaconda-tb
Comment 2 Alexey Derlaft 2013-05-30 10:05:27 EDT
Created attachment 754873 [details]
File: anaconda.log
Comment 3 Alexey Derlaft 2013-05-30 10:05:31 EDT
Created attachment 754874 [details]
File: backtrace
Comment 4 Alexey Derlaft 2013-05-30 10:05:35 EDT
Created attachment 754875 [details]
File: environ
Comment 5 Alexey Derlaft 2013-05-30 10:05:41 EDT
Created attachment 754876 [details]
File: ifcfg.log
Comment 6 Alexey Derlaft 2013-05-30 10:05:47 EDT
Created attachment 754877 [details]
File: lsblk_output
Comment 7 Alexey Derlaft 2013-05-30 10:05:52 EDT
Created attachment 754878 [details]
File: nmcli_dev_list
Comment 8 Alexey Derlaft 2013-05-30 10:05:57 EDT
Created attachment 754879 [details]
File: packaging.log
Comment 9 Alexey Derlaft 2013-05-30 10:06:02 EDT
Created attachment 754880 [details]
File: program.log
Comment 10 Alexey Derlaft 2013-05-30 10:06:07 EDT
Created attachment 754881 [details]
File: storage.log
Comment 11 Alexey Derlaft 2013-05-30 10:06:13 EDT
Created attachment 754882 [details]
File: syslog
Comment 12 Alexey Derlaft 2013-05-30 10:26:50 EDT
I can start installer if I type "DISPLAY=:1 anaconda" in tty
Comment 13 Fedora Blocker Bugs Application 2013-05-30 10:37:54 EDT
Proposed as a Blocker for 19-final by Fedora user ignatenkobrain using the blocker tracking app because:

 Installer must be start
Comment 14 Adam Williamson 2013-05-30 14:11:37 EDT
Can you please re-try this with a different USB stick and confirm whether it still happens? We can't see an obvious reason for this problem and we haven't seen any other reports of it, so it may be to do with your stick.

Discussed at 2013-05-30 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . Agreed to delay blocker evaluation for further input from the reporter and the babel developers.
Comment 15 Alexey Derlaft 2013-05-30 14:30:25 EDT
>Can you please re-try this with a different USB stick and confirm whether it still happens?

Yes, it still happens. I've also tried another USB slot.
Comment 16 Felix Schwarz 2013-05-30 14:36:23 EDT
Looks very strange to me - I can't think of a reason right now why this should happen in Babel (short of corrupt data or some OS bug). I assume the F19 beta netinst should be ok to reproduce that? Is there anyone else who can reproduce the issue?
Comment 17 Adam Williamson 2013-05-30 14:46:40 EDT
so far this is the only report we have, but I'll try and test it later. I don't think I've tested a dd'ed netinst.iso yet.
Comment 18 Alexey Derlaft 2013-05-30 15:00:52 EDT
I've tried this USB on another laptop, it works perfectly.

Problem with my hardware?
Comment 19 Adam Williamson 2013-06-03 13:10:03 EDT
Discussed at 2013-06-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-03/f19final-blocker-review-2.2013-06-03-16.00.log.txt . As no-one's been able to reproduce this and even the reporter can't on another system, this is tentatively rejected as a blocker: it can reproduced if we find more people are hitting it.

Alexey: it kinda looks that way. Have you tested the memory on the affected system?
Comment 20 Felix Schwarz 2013-10-02 14:43:55 EDT

*** This bug has been marked as a duplicate of bug 963267 ***

Note You need to log in before you can comment on or make changes to this bug.