Bug 969051 - RPM files with non-standard names are not handled properly
RPM files with non-standard names are not handled properly
Status: CLOSED DUPLICATE of bug 1101168
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.1.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 10:44 EDT by James Findley
Modified: 2014-09-22 20:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-22 20:12:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Findley 2013-05-30 10:44:21 EDT
Description of problem:

If the RPM has a name that doesn't match the expected name-version-release.arch.rpm naming scheme, pulp does not handle this properly.

The file is uploaded, and metadata is generated, but the href points to name-version-release.arch.rpm not the actual RPM name

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rename an rpm file to name-version.arch.rpm
2. upload to pulp
3. attempt to install the file on a client

Actual results:

Yum cannot download the RPM


Expected results:

Yum downloads and installs the RPM

Additional info:
Comment 1 Chris Duryee 2014-09-22 20:12:24 EDT
I believe this was fixed as part of bz 1101168. If you still run into this issue in the latest release of pulp, please re-open this bug.

*** This bug has been marked as a duplicate of bug 1101168 ***

Note You need to log in before you can comment on or make changes to this bug.