Bug 969076 - DVD Installation stops with "/dev/root does not exist"
DVD Installation stops with "/dev/root does not exist"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 11:25 EDT by Stephen Gordon
Modified: 2013-10-01 20:23 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 20:23:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SOS Report (76.03 KB, text/plain)
2013-05-30 11:25 EDT, Stephen Gordon
no flags Details
Journal contents. (2.79 MB, text/x-log)
2013-05-30 12:05 EDT, Stephen Gordon
no flags Details

  None (edit)
Description Stephen Gordon 2013-05-30 11:25:32 EDT
Created attachment 754935 [details]
SOS Report

Description of problem:

Booting the F19 Beta DVD and selecting installation get:

    [ OK ] Reached target Basic System.
    dracut-initqueue[369]: Warning: Could not boot.
    dracut-initqueue[369]: Warning: /dev/root does not exist
             Starting Dracut Emergency Shell...
    Warning: /dev/root does not exist

    Generating "/run/intramfs/sosreport.txt"

At this point I have been dumped to the emergency shell so was able to retrieve the sosreport.txt. I should also note there is quite a long gap after the last [OK] and the "warnings" that follow.
Comment 1 Stephen Gordon 2013-05-30 11:32:10 EDT
NB: I was using text mode because I thought it had locked bringing up the graphical Anaconda (due to the aforementioned delay after [OK]). Ultimately behavior is the same in either.
Comment 2 Stephen Gordon 2013-05-30 11:41:46 EDT
Hardware is Sony VAIO, model VPCEH. Installation media is a DVD burnt from Fedora-19-Beta-x86_64-DVD.iso, checksum (57ef66bdef119600887db0b5bba16e5a1f4625cbf1361c9f1c6416cf5432ba9e) checks out.
Comment 3 Stephen Gordon 2013-05-30 12:05:41 EDT
Created attachment 754960 [details]
Journal contents.

Booted with rd.debug and got some additional output in the journal. Same symptoms persist.
Comment 4 Stephen Gordon 2013-05-30 12:12:53 EDT
I checksummed the DVD itself (rather than the ISO I burnt from) and got the same checksum:

57ef66bdef119600887db0b5bba16e5a1f4625cbf1361c9f1c6416cf5432ba9e

This matches that provided on https://fedoraproject.org/static/checksums/Fedora-19-Beta-x86_64-CHECKSUM
Comment 5 Tim Flink 2013-05-30 12:14:43 EDT
re-assigning to anaconda as this is a boot problem on the installer DVD
Comment 6 Brian Lane 2013-05-30 12:43:28 EDT
What does /etc/udev/rules.d/90-anaconda.rules look like when you hit the debug shell? It should have a rule matching the cmdline's stage2 label in there that runs anaconda-diskroot

Have you tried booting the same DVD image from USB?
Comment 7 Stephen Gordon 2013-05-30 12:50:07 EDT
(In reply to Brian C. Lane from comment #6)
> What does /etc/udev/rules.d/90-anaconda.rules look like when you hit the
> debug shell? It should have a rule matching the cmdline's stage2 label in
> there that runs anaconda-diskroot

No such file exists.

> Have you tried booting the same DVD image from USB?

No, I don't have a USB available for this at the moment - I am about to try the netinstall disk though.
Comment 8 Stephen Gordon 2013-05-30 12:53:30 EDT
(In reply to Stephen Gordon from comment #7)

> > Have you tried booting the same DVD image from USB?
> 
> No, I don't have a USB available for this at the moment - I am about to try
> the netinstall disk though.

Interestingly the net install CD has indeed gotten past this point, I'm still concerned the "regular" DVD didn't appear to work though.
Comment 9 Kamil Páral 2013-05-31 05:01:34 EDT
We have tried burning F19 Beta x86_64 DVD again and booting in a BIOS machine and in a UEFI machine. Everything worked OK.
Comment 10 techtonik 2013-06-13 08:08:37 EDT
Tried to boot Netinst x86_64 ISO image from USB (unetbootin 584) and got the same error. Lenovo T400.
Comment 11 Kamil Páral 2013-06-13 08:19:38 EDT
I have seen this problem once, when booting from USB. The problem was that the kernel didn't detect the USB device and therefore couldn't find a partition with the particular label. "sda" (internal disk) was detected, but "sdb" (USB thumb drive) was not present at all. Unfortunately I don't have the logs.

When I rebooted and booted from the same USB medium (no change whatsoever), the system booted fine.
Comment 12 q2dg 2013-06-13 10:39:38 EDT
As user "techtonik" points, maybe this bug is related to 963003
Comment 13 Edward 2013-09-21 04:54:05 EDT
I get exactly the same problem installing the fedora 19 dvd image from usb on a Dell Inspiron 5721.
Comment 14 techtonik 2013-09-22 04:23:29 EDT
@Edwars, did you try x64_64 version on non-UEFI system?
Comment 15 Edward 2013-09-22 04:26:43 EDT
Yes, if I set the BIOS to boot up in legacy mode it installs fine. Here is the sosreport.txt I get when booting in UEFI: http://pastebin.com/4stUgUDN
Comment 16 Edward 2013-09-28 09:23:35 EDT
This is fixed for me now. It turned out to be a problem with the usb created by unetbootin. Using liveusb-creator instead works. See https://lists.fedoraproject.org/pipermail/users/2013-September/441380.html

Note You need to log in before you can comment on or make changes to this bug.