Bug 969081 - preserve msg_list:msg_preview and calendar:task size ratios on window resizes
preserve msg_list:msg_preview and calendar:task size ratios on window resizes
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 11:31 EDT by David Jaša
Modified: 2013-06-24 16:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 16:08:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-05-30 11:31:25 EDT
Description of problem:
When resizing evo mail window, the leftmost column stays of the same size (good) but so do rightmost columns in Mail and Calendar views (message preview in with vertical view and tasks preview respectively). When the resizes aren't slight, (e.g. for 1600x900 <--> 1920x1080 screen resolution ), the settings can not be adjusted to fit both resolutions and most importantly, if you switch from one window size to the other and back, the layout is different than in the beginning.

The constant ratio in Mail should rather be width_of_variable_width_columns:msg_preview, if possible.

The bug in Mail view is a regression from RHEL 2.28, in Calendar view is a new bug.

Version-Release number of selected component (if applicable):
evolution-2.32.3-1.el6.x86_64 (from evolution-232-testing)

How reproducible:
always

Steps to Reproduce:
1. resize Mail window with vertical message preview (resp. Calendar window)
2.
3.

Actual results:
message preview (resp. tasks preview) has the same width as before

Expected results:
message list and message preview (resp. main calendar view and tasks preview) are resized in proportion

Additional info:
Comment 1 Milan Crha 2013-06-24 10:42:50 EDT
One slightly related upstream bug report:
https://bugzilla.gnome.org/show_bug.cgi?id=651633

Though not that much related, because the behaviour to stick with one side of the paned view and change only the other side was done more as a feature, than a bug. It was due to wrong restore when the GtkPaned used real percent sizes.

I keep the decision on Matthew, I would just WontFix this.
Comment 2 Matthew Barnes 2013-06-24 16:08:48 EDT
Those panels are supposed to stay fixed during window resizes.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.