This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 969090 - SELinux is preventing /usr/bin/razor-lightdm-greeter from read, open access on the file /usr/bin/razor-lightdm-greeter.
SELinux is preventing /usr/bin/razor-lightdm-greeter from read, open access o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0cde0db24bb73666da5f5b096e5...
:
: 967199 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 11:48 EDT by Rex Dieter
Modified: 2013-07-03 20:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-57.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 20:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2013-05-30 11:48:55 EDT
Description of problem:
tried using lightdm-razor greeter
SELinux is preventing /usr/bin/razor-lightdm-greeter from read, open access on the file /usr/bin/razor-lightdm-greeter.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that razor-lightdm-greeter should be allowed read open access on the razor-lightdm-greeter file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep razor-lightdm-g /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:spamc_exec_t:s0
Target Objects                /usr/bin/razor-lightdm-greeter [ file ]
Source                        razor-lightdm-g
Source Path                   /usr/bin/razor-lightdm-greeter
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           lightdm-razorqt-0.5.2-9.fc19.x86_64
Target RPM Packages           lightdm-razorqt-0.5.2-9.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-301.fc19.x86_64 #1 SMP Mon
                              May 13 12:36:24 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-24 13:30:37 CDT
Last Seen                     2013-05-24 13:30:37 CDT
Local ID                      1b902a20-de27-4023-911e-05692f8c19b6

Raw Audit Messages
type=AVC msg=audit(1369420237.6:3301): avc:  denied  { read open } for  pid=31641 comm="lightdm" path="/usr/bin/razor-lightdm-greeter" dev="sda3" ino=2623303 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:spamc_exec_t:s0 tclass=file


type=AVC msg=audit(1369420237.6:3301): avc:  denied  { execute_no_trans } for  pid=31641 comm="lightdm" path="/usr/bin/razor-lightdm-greeter" dev="sda3" ino=2623303 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:spamc_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1369420237.6:3301): arch=x86_64 syscall=execve success=yes exit=0 a0=1956d60 a1=19567c0 a2=1953b10 a3=6c2f7273752f3a6d items=0 ppid=31639 pid=31641 auid=4294967295 uid=990 gid=986 euid=990 suid=990 fsuid=990 egid=986 sgid=986 fsgid=986 ses=4294967295 tty=(none) comm=razor-lightdm-g exe=/usr/bin/razor-lightdm-greeter subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: razor-lightdm-g,xdm_t,spamc_exec_t,file,read,open

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-300.fc19.x86_64
type:           libreport
Comment 1 Rex Dieter 2013-05-30 11:51:45 EDT
*** Bug 967199 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-06-24 07:59:09 EDT
commit c94a02bcbb44a436d6bed90197c32aed15eab124
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Jun 24 13:48:56 2013 +0200

    Fix labeling for razor-lightdm binaries
Comment 3 Adam Williamson 2013-06-25 14:56:57 EDT
No. LightDM bugs are not blockers. lightdm is not used on GNOME or KDE.
Comment 4 Tim Flink 2013-06-25 15:13:31 EDT
-1 blocker: LightDM is not used with any release-blocking DE, this does not violate any F19 release criteria
Comment 5 Jaroslav Reznik 2013-06-26 04:29:29 EDT
-1/-1 - not a blocking desktop component and it's really late to include it in final release (at least with current state, could be reconsidered as FE - depends how big the impact is).
Comment 6 Miroslav Grepl 2013-06-26 04:46:39 EDT
There are builds

http://koji.fedoraproject.org/koji/buildinfo?buildID=429099

with a fix.
Comment 7 Adam Williamson 2013-06-26 11:31:04 EDT
We have three -1 blocker votes, setting rejectedblocker.

mgrepl: it doesn't really matter at present, but note we really need updates in bodhi for blocker/FE fixes, not just builds in koji.
Comment 8 Miroslav Grepl 2013-06-26 11:34:46 EDT
Yes, I know. I just wanted to tell we have builds for a quick test.
Comment 9 Fedora Update System 2013-06-26 16:18:16 EDT
selinux-policy-3.12.1-57.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-57.fc19
Comment 10 Fedora Update System 2013-06-27 11:48:40 EDT
Package selinux-policy-3.12.1-57.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-57.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11846/selinux-policy-3.12.1-57.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-07-03 20:54:38 EDT
selinux-policy-3.12.1-57.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.