Bug 969118 - cdrom is "disconnected" after first reboot
cdrom is "disconnected" after first reboot
Status: CLOSED DUPLICATE of bug 459779
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 12:55 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2013-06-12 16:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 16:15:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-05-30 12:55:06 EDT
Description of problem:
After going through the "Create a new virtual machine" dialog with a live CD, CD is "disconnected" and the machine fails to boot (no bootable media) after the first reboot. After "reattacing" the CD image, subsequent reboots work fine. I'm not entirely sure if this is expected behaviour, reporting just in case.

Very similar to #244802.

Version-Release number of selected component (if applicable):
host:
qemu-kvm-1.4.2-2.fc19.x86_64
spice-server-0.12.3-1.fc19.x86_64 
virt-manager-0.10.0-0.5.gitde1695b2.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a new virtual machine through virt-manager, type Linux|Fedora18 with testday-20130530-i686.iso (which is a live cd and doesn't install to disk) and a hard disk.
2. Reboot the VM.
3. No bootable image found, the CD is "disconnected".

Actual results:
I'd expect the CD to be there until I "disconnect" it explicitly.
Comment 1 Cole Robinson 2013-06-12 16:15:25 EDT
There is no explicit way in the 'New VM' wizard to say 'this is a livecd'. There's a trick that if you tell the wizard 'no storage' we keep the CD attached and say to always boot off the cdrom.

We could always keep ISOs attached, but it's kind of a problem with doing that and host cdrom passthrough like /dev/sr0 so we would need to differentiate.

Either waying duping to the existing RFE for this stuff

*** This bug has been marked as a duplicate of bug 459779 ***

Note You need to log in before you can comment on or make changes to this bug.