Bug 969123 - Update to 0.2.8 slows down Totem's launch
Update to 0.2.8 slows down Totem's launch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grilo-plugins (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 13:20 EDT by Piotr Drąg
Modified: 2013-06-07 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: grilo-plugins-0.2.8-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 23:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pstack of starting totem (11.76 KB, text/plain)
2013-05-30 16:54 EDT, Piotr Drąg
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 701336 None None None Never

  None (edit)
Description Piotr Drąg 2013-05-30 13:20:58 EDT
Description of problem:
After installing grilo-plugins-0.2.8-1.fc19 Totem starts in half a minute (even spawning the "Application is not responding" dialog sometimes), instead of just in seconds. It works fine afterwards.


Version-Release number of selected component (if applicable):
grilo-plugins-0.2.8-1.fc19.x86_64
grilo-0.2.6-1.fc19.x86_64
totem-3.8.2-1.fc19.x86_64


Everything's fine with grilo-plugins-0.2.7-1.fc19.x86_64.
Comment 1 Kalev Lember 2013-05-30 14:24:51 EDT
Can you check what it's doing at startup when it's frozen? Might be easiest with pstack:

 1) Install the debuginfo packages:

    $ sudo debuginfo-install totem grilo grilo-plugins

 2) Start totem, and while it's in the long startup delay:

    $ pstack `pidof totem`
Comment 2 Piotr Drąg 2013-05-30 16:54:49 EDT
Created attachment 755045 [details]
pstack of starting totem
Comment 3 Kalev Lember 2013-05-30 17:01:40 EDT
Looks like it's resolving "www.magnatune.com" hostname.
Comment 4 Kalev Lember 2013-05-31 05:26:08 EDT
I have filed it upstream: https://bugzilla.gnome.org/show_bug.cgi?id=701336
Comment 5 Fedora Update System 2013-06-06 10:43:43 EDT
grilo-plugins-0.2.8-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-9229/grilo-plugins-0.2.8-2.fc19
Comment 6 Fedora Update System 2013-06-06 13:28:37 EDT
Package grilo-plugins-0.2.8-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grilo-plugins-0.2.8-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9229/grilo-plugins-0.2.8-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-07 23:32:33 EDT
grilo-plugins-0.2.8-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.